Serious issue with Photolab 4 (Mac) using DeepPrime


I have some big issue when exporting photos using DeepPRIME noise reduction that renders he feature unusable. When the process finishes exporting the first photo, the GPU reaches maximum load (i guess this is normal) and fans speed up to 100%, but I also loose video output (my screen turns to black). The export process than stalls and the only thing I can do is a hard reset of the computer.

It happens every time I try to use this feature…

Here is my setup :
Mac Pro 5.1
MacOS Mojave 10.14.6
Radeon RX 580 (Saphire Pulse)

Any help is appreciated, thanks

Try using DPL without GPU. You can turn it off on the last tab of DPL’s settings. This will slow down the export, but it might help circumvent the issue you describe.

Hi @Jero123,
If you haven’t yet, have a look at those pages on our FAQ:


Hello @Jero123,

Could you confirm that the RX 580 is connected internally and not externally (eGPU)?

To allow us to get more input, please follow these steps:

  • Download
  • Unzip the downloaded file (a double-click is enough). A file ‘DxODiagnostic.command’ will appear next to where you downloaded it.
  • Reproduce again the issue and restart your Mac if needed
  • Once the problem is reproduced, simply open the script (double-click) ‘DxODiagnostic.command’ to execute it. If macOS tells you that this files cannot be opened because it comes from an unidentified developer, close the alert, then right-click on the script in Finder and choose “Open”. Then choose again “Open” in the dialog.
  • A Terminal window will open, and ask for your password. This is the password of your user account. It is normal if you don’t see characters appearing in the Terminal as you type your password. Once in, followed by the Enter key, the script will run and indicate to wait for the data to be collected.
  • The script finishes when the line “[Process completed] is displayed.” Just before, a message states that an archive has been created on the desktop, along with its name (in the format “DxODiagnosticData- {date / time}.zip “
  • Please send us this zip file through using your forum user name instead of the ticket number and notify us.

That script assumes that the user running PL has administrator privileges, which is a bad assumption.


I could reproduce the issue once more and I have uploaded the diagnostic report. The “crash” occured at something like 21h00 - 21h10 local time

PL was able to process some of the pictures in the batch I exported. This time, export took something like 10 seconds per photo.

I can confirm that the RX 580 is connected internally and is not an eGPU

I tried running the export using the CPU Only parameter. It works, even though the process is quite slow (as expected). Between 2 to 3.5 minutes for each photos. So it is related to the GPU.

I will reproduce the issue and get back to you with the diagnostic report.

I ran into some crashes related to my eGPU-setup with a Vega 56 on macOS 10.15.
It happened during export while using Deep prime.

I did some tests with Heaven

And after a few minutes I saw the same crashes there as and after some googling I read a lot of threads related to weak power supplies and poor thermal heatsink paste causing the card to go black.
I went from a 460W PSU for the Vega to a 1200W but the crashes occurred anyway.

I then removed the heatsink, cleaned off the old paste, applied new thermal paste and put it all together.
After that everything have been rock solid.

1 Like

Hi there,
Thanks for your detailed feedback!!
So, in your case it seems to be more related to overheating due to poor thermal dissipation on your GPU dye…Could this be also the case too for the issue @Jero123 is having?

@Jero123 could you run a stress test on your GPU, like for example using Uningine Heaven?


The logs indeed show an error during DeepPRIME processing at 9.07pm, but unfortunately without much useful information. One minute later, system logs show 3 attempts to restart your GPU, followed by the reboot.

I would expect you to find a few Kernel_[…].gpuRestart files in “/Library/Logs/DiagnosticReports” or in “~ /Library/Logs/DiagnosticReports”. If you find these, please upload them through and notify us.

Without more information for now, I suspect either a hardware failure, heat issue or a bug in macOS 10.14.6. Running the above mentioned benchmark tool could give a hint.

Unfortunately, your 2010 Mac Pro does not support macOS 10.15, so it does not look possible to give a try with running PhotoLab 4 on macOS 10.15 to check if the issue comes from macOS 10.14 system or GPU drivers.


As requested, I have uploaded the gpuRestart file, even though it doesn’t seem to say much (report data is empty). It refers to a tailspin file, but I cannot find it, is this normal ?

I did run the above mentionned benchmark without any issue. I also tried to run geekbench (OpenCL and Metal) and they also ran without any issues. Along with the gpuRestart file, I have uploaded the benchmark results.

I also tried to use MacFanControl to force GPU fan speed to maximum power. Temps did not go above 75 C before it crashed (according to sensors).

Thank you for the tests you made!
@Lucas what’s the next step then?

Thank you @Jero123 for the files, we will investigate and get back to you once we have more information.

As you already found out, in the meantime you should restrict DeepPRIME to CPU only in Advanced Preferences.

Hi @Jero123, Lucas pinged me on this issue as I used to have the same hardware as you do, and never had any trouble with DeepPrime with that configuration.

I can see one obvious thing that could cause this: the power cable for the GPU. Could you tell me which one you used: the one supplied with the GPU (or that was already in the Mac Pro), or did you buy a special one?

1 Like

Hi @kettch,

My Radeon RX580 is wired to the motherboard using a double 6 pin mini to 8 pin power cable

Did you use something similar?

Yes, that’s the right cable indeed. It should have enough power like that, and all reports I’ve heard about the card shutting down were because a single cable was used instead of that.

So I’m afraid there’s another issue, and I’ll have to send that back to Lucas for more investigation.

In the mean time, I’ll try fetching a new cable, maybe mine is defective… I’d be surprised since there is no issue when running other GPU intensive apps like the benchmarks mentioned above, but who knows.

I’ll keep you updated

From the people that had it, the GPU not having enough power would actually shut down the whole computer, I just checked. So if that’s just the GPU restarting, that’s probably not the cable at all.
We discussed a few things to look into with Lucas so he should contact you soon.

I have not overclocked the GPU myself, but I cannot confirm it wasn’t when I initially bought it. I’m not sure how to revert it to it’s original factory settings if it has been OC.

I’ll look into that. Concerning the PSU, the unit in a Mac Pro 5,1 is rated for max 980 W. Even though I’d be surprised it changes anything, I’ll try disabling other devices and run Deep prime during the weekend, to see if changes anything.

I’ll keep you posted.


Yeah, I understand I can do this using the windows AMD software, but will this profile get “burned” on the GPU and stay the same once I put it back in my Mac Pro ?