SEP3 performance

Downloaded and installed Nik4 today. My initial experience with a short trial of Silver Efex 3 is a major disappointment.
When using the filter within Photoshop CC, new version seems extremely slow and unresponsive compared to previous version. After making any change, whether to a global setting or as applied to a control point, there is a lag of 2 seconds to 5 seconds or longer before that change is seen.
In contrast, similar changes in Silver Efex 2 happened nearly realtime on the same computer.
Response is better when launched from Lightroom. However, this is not how I usually work as I combine filters, multiple adjustment layers and masking.
So far the upgrade seem a waste of money to me.


Same performance issue on Windows 10. There is an option in Silver Efex to use the GPU, but it does not seem to use it. I tried on two different machines with two different GPU (Nvidia 1050 and Radeon RX580) but I can’t see any access to the GPU resources, only to the CPU. According to the release notes of Silver Efex these two GPU should be compatible. Each modification of a control point push the CPU to 100%. Loading Silver FX in standalone mode does not help.
A technical detail: The executables of Analog, Color Efex, Define 2, HDR Efex, Perspective Efex and Sharpener Pro 3 are under C: \ Program Files \ DxO \ Nik Collection \ in their respective directories. Those of Silver Efex and Viveza are under C: \ Program Files \ DxO \ Nik Collection \ bin. This inconsistency of structure seems to indicate a developement mess up.

Hi Gauthier,

I think it’s just the case that SEP does not use the GPU much at all (compared with, say, PhotoLab - which, for DeepPRIME processing, uses the GPU to the max.) … Your findings are much the same as for my GEForce GTX 1650.

No - it’s a result of transitioning: SEP & Viveza were redeveloped for the Nikv4 update - the other tools were (largely) untouched. I expect all tools will end up in the bin(ary) folder once all are fully updated.

John M

I also noticed that local and global slider response time in Silver Efex Pro was sluggish when I installed it the other day and I was disappointed by that. I export 16 bit Tiff images to it from within PhotoLab 4 Elite.

However, I just went back in to test it again to get a better idea of how slow the response time is, and was surprised to find the response time was now virtually instantaneous for local and global settings! I am very pleased, of course, but I can’t account for the response time improvement, I just wanted to share my experience.

Mark .

Why do you think that indicates a development mess up?


Hi John,
Thanks for your reply. It will be interesting could DxO explains when and why the GPU is used. There is no GPU option in Viveza by the way.
Right now Nik 4 is running on 3 different technologies: The legacy monolithic one, QT 5.6 for Perspective Efex (a 2016 version), and QT 5.13 for Silver Efex and Viveza (a version not supported anymore by the standard QT support, why not using a more recent or a LTS version?). For a programming/testing/maintaining perspective, it is inconsistent and a mess (the bin folder even still contains a test structure). I understand the current version of Nik 4 is transitional but Nik 3 was running fine and, in my opinion, DxO could, or should, have wait to complete the transition to the new framework for all the modules, at least the ones Nik 5 will have, and offers a more stable and easier to maintain version, this not only for the customers but also for DxO tech support and the company image of excellence.

Hi Mark,
See my reply to John M (without mentioning in this reply than if Silver Efex and Viveza in version 3 was + -64Mbs and + - 4 files, the version 4 of these same two modules is 373Mbs, 867 files and 194 folders, some to my understanding unnecessary, for interesting improvements but relatively minimal).

Thanks for your feedback. I tried again and yes it seems much responsive than the first times I tried. Why, this is the 59.99 Euro upgrade question. I guess support is working hard now.

I have the same experience on macOS and PhotoLab 4.3!

1 Like

I see you’re posting similar comments in multiple threads, Manfred (!)

Is it that your slow experience is related to using SEP as a filter/plug-in to PhotoShop ? - - That may explain why my experience of using it in stand-alone mode is quite different to yours (?)

John M

Hi John,

I started a thread because I discovered a problem with SEP3 on my end. This comment here was just to let @johdavmal know that she/he is not alone, so there must be something wrong with SEP (or maybe the whole Nik Collection 4).

My problem has to do with starting the Nik Collection Plugins from PhotoLab 4. I do not use them stand alone.

1 Like

Have had a not particularly helpful response to SEP3 performance issues from DXO support (in italics):

Below is a list of system requirements that need to be met or exceed to get the best performance from Nik Collection 4 on a Mac.

• Intel Core™ i5 or higher
• Apple M1 system
• 8 GB of RAM (16 GB recommended)
• 4 GB or more of available hard-disk space

Video requirements:

• Starting from: NVIDIA GeForce 8 Series, ATI Radeon HD2000 Series, and Intel HD Graphics 2000 Series.
• If no compatible card is available, GPU acceleration will be disabled, and the CPU will be used.

This is confusing as DXO’s site currently states:

“Nik Collection 4 by DxO, released on 02 June 2021, is NOT currently compatible with M1 and ARM. Compatibility will be added in a future minor version update.”

As my system meets the requirements, save having an M1 processor, the response basically implies I would need to upgrade 2 18 month old systems costing several K in order to run an upgrade costing £50! Given the considerably more expensive Adobe products I run function perfectly, I suspect DXO and I will be parting company.

Apple M1 should not be a requirement, maybe in 10 years…

These are the Mac requirements according to DXO’s website:

System Requirement Mac

  • • Intel Core™ i5 or higher
  • • 8 GB of RAM (16 GB recommended)
  • • 4 GB or more of available hard-disk space
  • • 10.14 (Mojave), 10.15 (Catalina), 11 (Big Sur)
  • • Adobe Photoshop CC 2020 through 2021
  • • Adobe Photoshop Elements 2020 through 2021 (apart from HDR Efex Pro 2, which is not compatible with Photoshop Elements)
  • • Adobe Photoshop Lightroom Classic CC 2019 through 2021
  • • DxO PhotoLab 4 and later
  • • Serif Affinity 1.8 and later (apart from Perspective Efex, which is not compatible with Affinity)


Mark, I have put in ticket to customer support on the issue of the time lag that I experienced using Silver Efex Pro 4. It was about 3 to 5 seconds delay between when I would make a change to a control point setting and when I saw the results. I was running it from Affinity Photo. So, when I saw your post this evening I thought I would try that. And, when running standalone the change results displayed immediately. However, it wasn’t long until the time lag I had previously experienced showed up. And, once the time lag increased it didn’t decrease. It seemed like over a period of time the Silver Efex Pro 4 code was struggling to find the resources it needed in order to run. My setup is Mac mini M1 (2020) 16GB memory and 994GB free on a 1TB hard drive Big Sur 11.4.

UPDATED: July 6, 2021 Downloaded Nik Collection 4.1.0 release and the problem I described here has been fixed. Using the same test that I experienced the time lag now shows changes immediately with absolutely no time lag on my set up. Customer Support was excellent as was the development team response.


I’m running on Windows so it is not surprising that our experiences might be different.


Same very slow performance here on M1 MacBook Pro. It takes 3-4 seconds to see a change in the image after moving a slider. Sluggishness is the same in standalone and running in PS under Rosetta. Previous version was fine.

Indeed, I’ve responded to support to the effect. I get the feeling I was sent a ‘generic’ holding response, as the experience I’m having (delays of 3-5 secs) seem pretty much the same as others are describing. My system specs should be fine!

  • Processor: 3.4 GHz Quad-Core Intel Core i5
  • RAM: 32 GB 2400 MHz DDR4
  • GPU: Radeon Pro 560 4 GB
1 Like

I gave up until they have a workable update and stepped back to NIK v3. Works fine, no delay or sluggishness.

1 Like

I’m very glad to hear that. I’m guessing Nik 4.1 was just released. I believe the version I currently have is 4.08. I don’t know if this new release is strictly for Macs, but I’ll check to see if it’s also available for Windows later today. Hopefully this new release will resolve some of the other issues people have posted about.