SEP image doesn't return to PL 6

Moved RAW image from LR to PL 6 and edited. Exported directly to SEP and edited there. Applied edit. Photo disappears and SEP closes but photo not returned to PL (or to LR). All on Mac Monterey. What step did I miss?

If I understand you correctly, then I think this is the explanation for what you’re seeing:

When you export from PL6 to SEP, PL6 creates a new RGB file (probably a TIFF file) for SEP to edit and that’s all. (PL6 won’t change which file it has currently selected for editing.) SEP will save its edits to that file which PL6 created and close. Nothing else will happen. SEP will not cause PL6 to change its selection to the RGB file that SEP just updated - you have to do that yourself using the image browser.

Hi. I’m not understanding at all. All that’s in the image browser is the color version of the image. Since I originally started with a RAW LR image, When I transferred it PL place it in an area called LR Projects. I cropped that imaged and exported to SEP. When I couldn’t find it, I tried again and you are correct, it’s a TIFF. So now I have the TIFF in SEP (I didn’t try to find it elsewhere again) and the original cropped file in PL’s LR Projects. Where would I find the updated SEP RGB TIFF file? Thanks

Second reply… I tried a different file with SEP and no issue at all. It came back to PL with the correct tonality.
I tried the troublesome file again and now it returns to PL but, while it says it’s a NIK TIFF and I only sent the file to SEP, it is identical to the file I exported. It is a file that is still in color. Very weird.

I am the original poster of this question. Both SEP and CEP have successfully worked on a file or 2 each since I first posted. Now 2 different results have occurred with a new file–either result is what I expected to happen.
I took a RAW dng file from LR and moved it to PL 6 where I applied a general purpose B&W preset, cropped and applied Deep Prime XD. I exported to SEP as a TIFF without problem and edited there and applied the edits I wanted to the file. It exported back as a general purpose B&W (no edits applied). What I sent is exactly what came back but as a separate copy of the file I sent. Tried again and got still another copy of a basic B&W file back. Tried again and this time got nothing back at all. Tried again and again nothing returned. I don’t understand this as I’ve had no issues with other files.
I then tried to take my underlying original image back to LR and tried SEP from there. I “found” my “unable to be located” original in PL and linked it to LR. Cropped in LR and edited in SEP. When I went to apply edits the message I got in LR was that the original file could not be found. This is very weird since the original file was then sitting next to the basic B&W that SEP returned (with an ! to LR).
Thoughts? I really do want to get this under control and edit this image in SEP. Thanks!

Yours isn’t the first report I’ve seen of B&W files being returned without edits - but I can’t find the other report in a search and never heard what the cause was. I suggest creating a technical support ticket at

Unless someone else here who uses Adobe on Mac with PL and Nik can comment?