Selective tool does not auto-open

I just purchased the latest and greatest Nik collection
I am currently using a Mac with Mojave, and Photoshop latest and greatest.

The selective tool does not AUTO open when I open photoshop.
I’ve tried the instructions on this forum and set my setting in the tool but it’s not working for me.

Hello, @ima999!

We modify the behavior of the Selective Tool in Nik Collection 3, so now it automatically appears, when you open the image in Photoshop (not on Photoshop launch as before).

Could you, please, try to open an image in Photoshop and see does the Selective tool launches automatically or not?

Let us know if you still have a problem.


The selective tool does not work for me either. I upgraded and installed the Nik Coll 3 last night. When I opened PS the first time the selective tool opened, but it was unresponsive and crashed, error report attached. After several tries I uninstalled all previous DxO software and reinstalled Nik Collection 3. Now I can’t get the selective tool to open at all.

How do I get it to open? I have tried File > Automate > Nik Selective Tool 2… Nothing happens.

I’m running Windows with latest updates, latest Photoshop Updates, all drivers updated…

Does not open automatically for me either.

Hi, I’m hoping that I can answer my own question / problem here re the Selective Tool not opening / crashing. I was searching for the solution to Lightroom Classic / Photoshop issue and I came across a user that said disabling Windows User Account Control in the registry fixed his issue.

I disabled UAC using Regedit, and sure enough that problem was fixed. I wondered if that could also be the problem for the Nik Selective Tool. Yep, the Selective Tool now works as adverstised…

I hope this also helps others having this issue.

I had the previous version still installed when I setup the newest one. I assumed that the installer would ask me to remove it, but it did not. The new selective tool did not open for me at all. I uninstalled both versions completely, rebooted, and reinstalled Nik Collection 3. The selective tool did not open at startup, but did after I opened an image in Photoshop. I attempted to adjust the settings for the selective tool and it crashed Photoshop.

I restarted and the selective tool did not appear to open, even after an image was opened. When I put my mouse over the area where the selective tool was last seen, I saw a blue circle indicating that something was running there. I clicked the area and the outline of the selective tool appeared, then a notification told me that the tool had stopped running. It provided me with the options of waiting for it to respond or to close it. I chose to wait for it to respond, but it never did.

I use this suite of plugins for all of my work and really want for it to work properly. Do you have any suggestions on how to fix it?

It has been a week without any update to this thread or an answer from DxO. In the meantime, I’ve uninstalled all DxO applications, all Adobe applications, cleaned my registry, updated video card drivers, ran several computer clean up tools, then reinstalled Adobe Photoshop and Lightroom. I reinstalled Nik Tools. The Selective Tool runs great the first time, then stops working when I open a second image to edit.

What is the solution?

I have the same problem in windows as morgo, is this a problem you guys are working on? and if so in what time could this issue been fixed?
i can acces the menu in photoshop in the filter tab but it would be great if it also worked as before. Now i feel a little bid ripped of after paying for an update that does not completely works.

I have the same problem. The Selective Tool appears exactly once after the new installation. After that it simply disappears. Reinstallation leads to the same result.
Windows 10 Prof. (up to date) Nik Collection 3, PS and LR (up to date).