Roundtripping from LR classic 12.1 to Photolab 6

Hello, Im having a issue Roundtripping from LR classic 12.1 to Photolab 6 and back to LR. I can send the imabe to photolab using the file > plugin extras > photolab 6 and have it open in photolab without issue. When I finish my edit and export it back to LR it does not appear in the library with the other images. I have tried several options and watched several videos, all to no avail. It even looks like photolab didn’t export it as a collection nor to the original image location. Im at a loss and could really use some assistance. Thank you Charlie

1 Like

In Lightroom Classic’s Library module, ctrl-click on the source folder and select “synchronize”.

This should bring up the images exported by DPR…unless you export to some other folder instead, in which case you’ll have to import or sync that folder.

Note: The above are workarounds until DxO fixes the bug introduced in the recent DPR2 update.

1 Like

Thank you so much for your insite…im greatful for the work around. I did eventually find the original exports and it did put an image in a DXO collection within Lr…however, only one time, after countless attempts. I’ll give the workaround a try and let you know. Thank you again

@charlie, yeah in this scenario, the Export back to LR takes an annoyingly long time, and then often the DxO-edited image seems lost in transition. It isn’t. The DxO edited image will appear/can be found in LrC, eventually. But I know the annoyance of which you speak. Until you get used to it, this can feel maddening.

Try this workflow which works for me (this first paragraph you already know and are doing correctly):
Import the image in LrC. Then with it highlighted, click File > Plug-in Extras > Transfer to DxO PhotoLab 6. (Going this way, as you know, rather than going in LrC Photo > Edit In > DxO PhotoLab 6… the Plug-In Extras route round-trips a DNG file, which I much prefer to the TIFF file you get using Edit In… After applying your edits in DxO, hit the button to “Export to Lightroom” and be sure to select, assuming this is what you want “Export as DNG (all corrections applied).” Hit “Export.”

Now don’t touch anything; let it do its thing. At least on a Win10 PC, you can watch the DxO PL icon in your taskbar. You’ll see a delay of a number of seconds where nothing happens, and then that icon will display a green progress bar as it does the Export.

Still don’t touch anything. Your screen should minimize PL and switch to LrC. But nothing happens. Maybe for a minute or more, depending on your hardware–and note, the first round-trip export of the session back to LrC may take longer than subsequent transfers. You may briefly see something happen in the upper left of LrC as the edited image finally comes back into LrC. Then your LrC screen will suddenly shift and you’ll see your returned image. But as you say, it’s displayed in Library module in a Collections folder, not the folder you started in. No you didn’t ask PL or LrC to do that, but that’s how they roll. Just leave the image in the Collections folder. It’s more of a virtual copy than an unneeded duplicate taking up extra space. You can’t delete the image from the Collections folder, and don’t need to move it. Just leave it there.

Now in the left-hand column, scroll up, back to the folder from which you exported from LrC to DxO. Open the folder. The returned image file is in there, as you would see if you looked for it in Windows File Explorer, but you may… or may not… see it in Library or Develop module. If you can’t see it, try the Synchronization trick mentioned above, or try switching for just a second or two to a different folder and then come back. The DxO-edited DNG should eventually be visible next to the original image file in either Library or Develop module.

I prefer to stack the DxO edit with the original, so I just see the DxO file on top of the original image with a small “2” icon in the bottom row in LR. Note that LR considers the returned file to be stacked, but it’s a separate and individual image stack from the original. So what I have to do to display the stack the way I want is right-click the image in the bottom row, choose Stacking > Unstack, then ctrl-click both images, the DxO version first, right-click again and choose Stacking > Group Into Stack.

I don’t know why all this has to be so messy and unintuitive. No doubt Adobe and DxO would blame each other. But if you just roll with it, the round-trip works out eventually.

Once you’re comfortable that this is working as stated above, you can experiment with starting another image export from LrC to DxO before your earlier Export back to LR has reappeared; you don’t have to just sit there for several minutes. This works for me.


dxodm, thank you so much for the very detailed assistance. With that I have been able to locate the roundtripped images in the original import folder into Lr. However, what is not happening is the image showing up in the image strip along side the original. Further, on 2 occasions dxo created a seperate folder under the collection and placed the edit into, but not every time like it should. Its frustrating to say the least, making it impossible for multi-image projects. The roundtrip process should be seamless, ie Lr to Ps and back.
Is a fix in the pipeline or is this as good as its going to get?

1 Like

Roundtrips used to work, but something has gone wrong with the latest updates of DPL or LrC. The bug will eventually be removed.

Meanwhile, it might be easier to start processing in DPL and then import/sync the results into Lightroom’s catalog…not using the plugins at all.


Interesting. So I just rechecked with a new round-trip, and I do not have this bug.

I have LrC 12.1, DxO PL 6.2.0 Build 123, and Win10 Pro 22H2 Build 19045.2486. How about you, @charlie or anyone else experiencing it?

Try this to help diagnose what’s happening. Open LrC and PL 6 but not maximized in the screen. Also if you have Windows, open File Explorer (of course, Finder in Mac) not maximized and navigate to and open the folder you’ll be sending out the image from LrC to DxO. When you hit “Export to Lightroom” in DxO, watch that folder. In my setup, right when the screen transition back to LrC from PL 6 occurs, an additional file appears in Explorer with a “DxO” appended to the filename (but disregard any DxO .dop file you see; that’s not the one you need). It still takes the better part of a minute before the image pops in my Collections folder as well as back in Develop or Library module, next to the original. Maybe you, @charlie, won’t see it at all in Explorer in that folder. Try searching all of your Pictures folder to see if another “DxO” copy can be found somewhere else time-stamped when you exported to LR.

Meantime, if I were having this bug, until it’s fixed, I’d do what @platypus
suggests for a workaround.

1 Like

@charlie: Also another way to find it, if it went somewhere else. After the image appears in a Collections folder in LrC, right-click it there (ctrl-click on a Mac) and choose Show in Explorer [Finder]. What folder is it in? It’s supposed to be in the folder LrC used to send it to DxO.

1 Like

Ok, I’m sitting at my workstation now. It’s a Intel(R) Core™ i7-9800X CPU @ 3.80GHz 3.79 GHz; 32.0 GB of installed RAM; Windows 11 Pro; 22H2; build 22621.1105. Lightroom Classic 12.1; PL 6.2.0 build 103 (no update required)

Roundtripping from Lr to PL and back to Lr

Start Edit Process
select image in Lr and send it to PL using the file > plugin extras > transfer to PL 6

Make Corrective Edit and Roundtrip back to Lr

Select Export to Lr > Export as TIFF > View progress bar and “wait” > image files written to original Lr import folder. No images appear in the image strip nor in a DXO collection folder.

In Lr > right click and synchronize folder > wait > images now appear in strip. If you try to resynchronize for a second time you will get an error message operation not performed some files are unsupported or damaged.

Please let me know if I have this right. I’m still questioning why it opened 2 new collection folders, but only 2…Not one for each roundtripped image.

Very convoluted way to the workflow for sure.

1 Like

When things still worked in DPL5 on Mac a while ago, I found that a collection was created per batch, not one per image.

1 Like

Ok, that makes sense as I was working with a single image.

I have reached out to the DXO support team and have not received a reply as of yet. Perhaps there is someone from the support team monitoring the chat and can assist.

@charliehoffman, you are doing two things differently than I, who is not experiencing this bug… returning to LrC with a TIFF file rather than a DNG, and using Windows 11.

I don’t have a way to test round-tripping with Windows 11, but I wouldn’t be surprised if it turns out that’s at least part of your issue, because some apps are reportedly a little glitchy, particularly if you’re on the latest Win11 feature update, 22H2. guru Susan Bradley specifically recommends staying on 21H2 with Win11, not 22H2, because of odd glitches like this one. She does recommend updating to 22H2 for Win10, but not for Win11 at this point. You probably can’t go back now, so if this is your issue, you’ll have to wait for DxO/Adobe to find and fix it, which they should eventually. In the meantime, the @platypus workaround may work better.

I was able to Export a TIFF file back to LrC using the default settings in DxO for that purpose and see it in Develop module correctly. If you’ve changed the Export settings for TIFF exports, your mileage may vary. But it may well be Win11 22H2 that is not playing well with the LrC to PL to LrC roundtrip.

1 Like

Hi dxodm, that could be the route cause to the roundtrip issue. None the less update are enevatable and I hope this issue gets sorted out. In this current state and the issues it adds to my workflow…makes it difficult to stick with, even for one offs.

I think is note worthy, i still havent recieved a reply from DXOs support. That to me speaks volumes.

Thank you to all who chipped in and contributed to the thread.

May I suggest, you report to / note DxO about the above findings of @dxodm
(easier then to find the needle in the haystack)

1 Like

Ok I went back through all the suggestions and workarounds and I finally had success. It even opened up a new collection in Lr, as it should.

Here are the steps that seen to work

Lr to Pl

  1. Select Image > File > Plug in Extras > Transfer to DXO Pl 6

Return Trip to Lr

  1. In the right hand corner select > Export to Lr > Select Options > Export as DNG (with all corrections)
    THEN WAIT …It took my HP workstation 3min to return to Lr and create a folder in the DXO collections just for 1 image 24MB.

It’s great that with all the help here, together we got it to work. However, I have to say it’s not very practical given the large wait time just for one image. It would have to be a very special image with Pl as the only edit tool. Such roundtripping from Lr to Ps or Capture 1 is seamles and the task in a fraction of the time.

Thank you to everyone for helping me sort this out with wonderful solutions.


I have and provided them the link to this thread.

1 Like