Retouch Tool Mangled My Photos

Over the past couple days, I spent a great deal of time retouching 11 photos. Just as I was finishing the last photo, the image became distorted and the Correction Preview wheel began spinning in the thumbnails of all of the recently retouched photos. Every one of the photos I’d just painstakingly retouched had become distorted, apparently with misaligned retouch adjustments. No global adjustments had been applied to the photos after retouching.

I was unable to determine what caused this to happen and was forced to reset every image. I’ve now completely lost confidence in the retouch tool and will be forced to rely on Affinity or Photoshop Elements for retouching. Seems every time I clear an impasse in PL, another challenge soon emerges from the shadows. One step forward and two steps back.

I have seen and understood Joanna’s posting regarding her retouch tool issues. This one, however, seems more troubling as it was somehow able to effect an entire collection of images that were no longer being worked on.

Has anyone here had similar issues with the retouch tool?

I have reported this to DxO.

What is the “Correction Preview Wheel” ?

Sorry, I didn’t know what to call it. Looked at past forum posts and came across that term. Anyway, it’s two white semi-circles, each with an arrowhead at one end (forming an open circle) that spins around to indicate that the program is in the process of updating the preview of the image.

Screenshot 2024-03-03 at 8.57.10 PM

Which versions of PhotoLab and macOS are involved? How many repairs per image? Details about your setup?

I’ve had DPL getting sluggishly slow when I patched a lot of spots. According to activity monitor, resources weren’t overloaded, but YMMV.

I have had the same problem yesterday but I thought it was a mistake. I used Ctrl+Z to cancel a modification, in fact on my French keyboard Z and A are just near, so I probably typed Ctrl+A which selected ALL the folder.

Hi there Thomas

Just to let you know, you are definitely not on your own with this problem. We have an important image to restore, including white marks when it got dragged over a dirty floor.

We spent around an hour “removing” 469 of those marks and, all of a sudden, we got exactly the same thing as you and the image refused to show in the Ian editing window.

This is a RAW file that has had adjustments made to make it B&W along with a couple of geometry adjustments.

I am using PL7.3, because PL7.4 has another bug that I can no longer remember, so I reverted. But the problem of Retouch getting slower has been around for several versions. The only kludge we found was, if you can remember, to export to TIFF as soon as things start to get slow and then restart work on the exported TIFF until the same happens again, where we went through the same “wash, rinse, repeat” cycle.

I tried to report this but when support asked for the image file, it is a 45Mpx Nikon NEF file, which was too large to upload with the report. They have given me a separate upload URL, so I shall try to upload there.

We too are also seriously considering changing to Affinity Photo for retouching but it means relearning the reverse way of selecting the source before the destination, which isn’t as efficient as the PL way.

We are using Ventura 13.6, although, as I’ve said, the problem has existed for years.

Got the same problem 2 or 3 times.
But I don’t use this tool extensively.

Right! I have successfully uploaded the requested NEF and DOP files and had an acknowledgement saying that they will be passed to the developers.

Here’s hoping.

The bugs do really be mounting in 6 and 7 nearly every time I do some editing I get effected by one or other of them (discounting the poor local adjustment mess in 7!) The retouch is one I haven’t had with Windows. 4 photos yesterday and two times I had to close PL as it locked up with local editing. Tried both 6 and 7 and it locked up doing different images and adjustments.


Even though I don’t use a Mac, this was my first thought - accidentally selecting several images…

Thank you Joanna for putting my mind at ease that it was not some kind of misstep on my part that caused the problem. As a new user of DxO’s software I know that I’ve got a long road ahead of me before I feel competent. However, I’ve been using retouch-like tools in other programs on the Mac for many years to great effect. I don’t recall ever encountering procedural issues with any of them that require you to understand at what point in the workflow you can reliably employ the tool.

Regarding the problem I encountered, I’m still struggling to understand how the ten images that had already been processed could have been affected. Only one of the eleven files was open. The others were not selected. It seems really bizarre that the closed files could have been targeted to be altered in the same incorrect manner as the open file. And I was unable to undo any of the changes.

I tried restoring the open file’s dop and xmp files with Time Machine, but it had no effect. Assuming that the database, where ever that is, contains the undamaged corrections, but I didn’t want to go down that rat hole. So, a reset of all the images to their unaltered states was my only recourse.

I’m not all that fond of the process of moving files back and forth between programs, especially to achieve intermediate corrections that may require me to return to PL to finish up. Plus, there doesn’t seem to be a seamless way to move images between PL and other programs.

Until PhotoLab 7 I had only used Canon’s Digital Professional 4 to process RAW files. I’m relatively new to RAW processing, about 5 years, and have only owned one camera capable of generating RAW files.

I’ve been interested in processing digital images since the eighties. Not for profit, but often for work and personal gratification. Always on Apple hardware, beginning with the Apple II and a Koala Pad, perhaps the first personal computer graphics tablet.

Along the way I’ve encountered many programs with great promise - too many of them never fully realized their potential and disappeared, forcing hapless users to search out alternatives and adapt to yet another paradigm. I do hope PhotoLab is not on such a path…

In my case, it is the explanation as all the files add a green flag and the same list of modification was in the history.

Sorry, no message.

Indeed. I’ve got this bug in v6.

Opened DPL version 5 and started to add repair points to an image.

  • At around 120 repairs, the cursor started to lag behind mouse movement
  • At around 150 repairs, the lag made working painful,
    so I stopped and manually exported the .dop sidecar (I’ve disabled it as a rule)

Opened DPL versions 6 and 7 and imported the .dop file

  • Both DPL versions showed the repair masks (don’t foret to switch them on :wink:
  • Both DPL versions showed no lag, so I added another 50 repairs
    with DPL7 without adverse effects

Lesson learned:

  • Keep old versions of DPL in order to be able to repair defects by the hundreds

Looking at the database files, I found the following:

Notice how the DBs differ in size - even if we also consider the -wal parts.

Deleted the databases and had DPL re-read the sidecars. The database files were about the same size afterwards. Looks like the database collects loads of information about the added repairs (history, after all, each protocol entry includes all info about the respective repair) but even though the DBs were considerably smaller, the lag was still there in DPL5 and “advanced history” had advanced to Nirwana (was gone).

Well, well, let’s call it “room for improvement”.

This is what we were finding. Our “cure” was to export to TIFF and continue repairing on that exported TIFF until it started getting slow again. Then export again, etc. :face_holding_back_tears:

Yes, we just discovered that, sometimes, we open a repaired file and it appears that no repairs have been done, until we explicitly show and and then hide the masks. Weird or what?

We are currently working on our third iteration for a very dirty file and it seems to take a couple of hundred repairs to restart slowing down.

At this moment, it is Helen’s turn to do some de-spotting - the eyes get tired after the first few hundred on the nth iteration.

I am going to ruffle many feathers with what I am going to say…

PL is the wrong tool for the job. To do this type of editing, you need a proper pixel editor.

I have been restoring photos for about 30 years and I have never had this issue. Some of these old photos have hundreds of dust spots and other marks on them. I started with Corel PhotoPaint and now use Photoshop but any pixel editor will do the job. Even Faststone has a better Clone and Heal tool.

I do use PL to process the raw from a scan (with a scanner or a camera) then I save it as a 16 bit TIFF. That is then processed in Photoshop.


Having given this further thought, I believe the issue is entirely related to non-destructive editing of RAW files versus pixel pushing, as occurs in Raster based formats. With raster based images, each correction modifies the file in place, so further modifications that affect the size or geometry of the image need no special knowledge of prior modifications. Modifications to RAW files, however, don’t actually modify the file. Since modifications must be applied each time the image is viewed, local adjustments would have to somehow adapt to any changes in geometry. It seems unlikely that most, if not all, local adjustments could accurately be made to adapt to such changes.

Just thinking out loud, so to speak. These issues may already be obvious to many of you that have vastly more experience with RAW files than me. Still, though, the issues that I experienced with the retouch tool occurred without having intentionally modified the geometry of the images. Can the geometry of images be unintentionally altered during the normal course of applying corrections not specifically expected to do so?

Photolab 7 is a parametric editor and the edited file must be exported in order to show your edits. this is true for ALL files, whether RAW or otherwise.

I’m using PhotoLab 7.4.0 build 45

Mac OS 13.6.1 (Ventura)

Not a large number of repairs per image, but they were not small, as is usually the case. I was gradually blending/smoothing and lightening harshly lit skin on a closeup of a face.

The above is a very abridged version of a much more in depth response that somehow was dumped when I tried to reply.