ReTouch Broken PL6 not solved!

I just bought a DXO PL6 and after reading the post “ReTouch Broken PL6”, I confirm having this problem on the latest version of PL6 6.0.26 on Mac OS Monterey 12.6.1 with an Apple MacBook Pro (16 inch, 2021) M1 Max, 64 GB RAM. However, I have uninstalled and reinstalled the software several times with AppCleaner, tried several folders and photos, the problem persists.
It happens completely randomly with the same photo, sometimes it works correctly and sometimes some previous corrections disappear after zooming and moving in the image!
It’s very problematic, I have no solution, can we download an old version like PL5 while waiting for the resolution of the bug?

Are your video drivers up-to-date?

You probably won’t hear from DxO about your questions in this forum, so I suggest you open a request at Someone here might be willing to share a copy of PL5 for Mac, though, using a file sharing service. Best wishes.

Hello, @ gilogic
the known issue is confirmed as solved.
If you observe an issue, please open a request at as Egregius alsready suggested.

1 Like

Ok, but I have exactly the same problems as mentioned in the post of Lost_Manc, I have the impression that it is a question of zoom, in the history there is the mention “strock removed” which suddenly appears during a new correction but randomly and there we can be sure that one or more corrections have been automatically deleted!
So the problem is not solved with the new version.

Indeed, there was still an issue present. We have found it. The fix will be available with the next update.


Will the bug with non-existing blue mask ghosts that randomly appear when working with local adjustments be fixed eventually? That one has survived several full versjons of Photolab.