RESOLVED: PL 4.1 Original file disappears from image browser and viewer during export and reappears when export completes

I am running PL4,1 for Windows and noticed an odd new behavior during export that I hadn’t seen before.

When I export an image to disk, the image I am exporting from is removed from the image browser and reappears when the export has completed. I believe I have exported files since installing the 4.1 update two days ago and I don’t recall noticing this behavior before.

Thinking there was a data corruption somewhere I deleted the database and rebooted my computer, but the problem still persisted. I then did a repair reinstallation of PL 4.1 but the problem still occurs for every export.

Has any one else run across this problam?. I’ve been running PhotoLab almost every day for the last three years so I don’t believe this is the result of any user error or any confusion on my part.


Hi Mark. I’m running basically the same system you are. 20H2? I’m not experiencing this behavior. There was an update to windows 2 days ago.

Have you installed it?

Hi Mark (New Jersey),
I exported 2 RAW-files (different raw formats, DeepPrime activated, as TIFFs) in Library and Customize ‘mode’ – nothing disappeared while operation. As these 2 files are located on my scratch disk (M.2 storage), I tried with another file on a HD – just the same.
Hope that helps. :face_with_hand_over_mouth: I’m on Win 10 20H2 latest update (Dec 9th).

I forgot to mention that when the image disappears from the image browser It also disappears from the image viewer which then automatically switches to the image just to the right of it in the browser. After the export completes and the original image reappears in the browser, the viewer still shows the image to the right of it. My version of Windows 10 is current with all updates, including 20H2.


That’s really weird. Have you tried several different files, RAW and VC? I might even try turning off some corrections one by one such as DP or LA just to see if it makes a difference.

Any type of file I export, even a VC, with edits or without any edits applied, always results in the same behavior, I noticed this for the first time yesterday. I even tried uninstalling the latest Windows update, which was a feature update to 20H2, KB4562830, but after uninstalling and rebooting the problem remains. I am baffled.


Mark I know this is a dumb question, but is it possible that one of these in the third tier have gotten turned off somehow?

I resolved this issue. It was a result of some corruption somewhere. and was not related to filtering…

After backing up all my presets, workspaces, etc., I uninstalled PL4.1. Then I deleted all remnants of it in Programs and Appdata. I rebooted before reinstalling PL 4.1 and then copied back the presets and workspaces. I’m very familiar with all this so it only took around 15 minutes to do everything. When I tested again after the reinstallation the problem no longer occurred. Obviously something got corrupted somewhere, but it is resolved now.


1 Like

Yes, I’ve done that before. You never know where some components for programs are stored and when you delete “everything” you can lose something that you wanted to keep. Glad you got it sorted! :smile:

Uninstalls of PL4 do not delete everything as you know. There is a lot left behind. I think that is done purposely so people can reinstall it and not loose any of their settings, presets, workspaces etc. But for users who no longer want PhotoLab installed, a significant amount of data is left behind. Those of us who know where this data is located, can delete it manually, of course.