Resetting control line tool turns photo to colourful mosaic

Maybe someone else can also reproduce this. When I reset, by clicking on the circle symbol, the changes I made with the control line tool, my photo turns into sth. psychedelic. See the screenshot.
Only way to bring the photo back is to erase the control point.

Just tried another control point. Happening the same. So its not only the control line tool.
Clicking on the reset circle, even without having done changes before, leads to the shown result, with any of the control point tools.

Hello @KameraD,

What is your Mac model?
Do you get the same result in the exported JPEG?


Hi Lucas, no better, see screenshot :wink: Specs also see screenshot.

Ohne Titel

Thank you!
So it is not just a display issue.

Could you upload the source image along with its .dop file on, choosing “Forum” ticket and notify me once it is uploaded?


1 Like

Files uploaded
Just checked it with PL4, to be sure. No problems when resetting a control point.

Thank you, we reproduced on our side and will keep you updated.

1 Like

Any news on this? I just clicked the second time by mistake on the resect circle and ended up each time with the mosaic, having to delete the control point and do all the settings again. This is really annoying, sorry.
Must correct myself. All controlpoints have to be deleted :frowning:

It does seem to be only resetting either the Vibrancy alone or the whole control point, which includes the Vibrancy, that triggers this.

Instead of deleting the control point, you can just make a small adjustment to the Vibrancy slider and return it to 0 and, in my experience, that will restore the image to a workable state.

Then it’s just a matter of waiting for @Lucas and friends fixing it :sleeping:

1 Like

Thanks Joanna, I’ve tried everything possible. But I never got the idea with the vibrancy slider. Works perfectly and is a real time saver.

When I add only one new Control Line, it happens simply when I double clic either on vibrancy or on TSL, or if I reset the whole control point. Do this before changing any value.

After the bug appears, as soon as you start changing values and coming back to 0 as you explain, my trick to make it happen do not work 100% anymore.

Hey! Good catch! I hadn’t tried what you call HSL, in English, Hue.

@Lucas You might need too look at this as well.

1 Like

Confirmed. Did not notice this before. But luckily the workaround Joanna suggested, brings it back again.


Thanks to all of your feedbacks, we have identified the cause and a fix is on its way.

As stated above a workaround is to activate HSL or Vibrancy (inside Color) even with sliders at 0, it should get rid of the bug (even if it’s not ideal).


Also thanks for the info Matt.

Exactly the same happens to me, albeit in a different situation. When I add a control line (or two) to an otherwise unedited image and save the local adjustments to a preset, the same thing happens when I try to use the preset on another image.

System: Mac OS Big Sur 11.6, iMac 2020 5K 27’’ 3.8 GHz 8-Core Intel Core I7, 64 GB 2667 MHz DDR4,
AMD Radeon Pro 5500 XT 8 GB