Rename Selected Images is greyed out

Just discovered I should be able to do this but it’s greyed out. Selected 4 images, went to Rename Images, and it’s not working. I have version 4.1.3, running on 2017 iMac and OS 10.15.7

Hello denjes2,
I just tried on on a bunch of raw files and it works as expected.
What are you doing exactly?


I highlighted a group of files, went to Images: Rename Selected Images, and it’s greyed out. It does work for an individual file though. Tried in on iMac and MacBook Pro.

No problem here

Suggest you post a screenshot … Something’s NQR.


When I select a group to rename, it’s greyed out. Single image is fine. Am I missing something? This is from MacBook Pro running 11.3 beta. My iMac is humming Catalina with same results.

Yep, that looks strange: I see it has recognised that you’ve selected a group of images - as it reads “Rename Selected Images” … but I don’t know why it won’t let you select that option.

Can any Mac users out there offer a suggestion ?

John M

Are you using the Elite edition?
If I am right, batch renaming is only available in Elite, but not in Essential.

I am using Essential edition but the description of new things available in PhotoLab 4 doesn’t say it’s only available in Elite, at least here. If it is the case it only is available in Elite, then that’s pretty deceptive of them. It should be in both versions.

Batch renaming is an ELITE edition feature indeed.

As for being clear which features are in which edition,
DxO could make things more accessible and transparent.