Question about using watermark as a part of preset

So I just recently made a preset for myself with some basic adjustments that I always do plus included my watermark in it. So I just finished editing a large batch of photos which all are different edits not a one size fits all situation and what I typically do is I export 2 versions one watermarked and one not. But it seems I cant remove my watermark now, is this because it’s part of the preset? If so is there any way at all to remove this? I cant reset the photos or remove the preset because then I lose my edits in the RAW files.

Actually quick update…It doesnt seem to be related to the preset…I just tried a different batch of photos without the preset enabled, I added the watermark manually and I still cant remove it from these photos either. I have never had this problem before, not sure what’s going on now. I hit the delete trash icon on the watermark and nothing happens

Interesting problem. What OS and version of PhotoLab are you using? Can you provide a screenshot of the export settings you’re using for the non-watermarked version?

The latest 4.3.3 build on Windows

I dont have the watermark set through the export settings I have it in my image preset that it gets applied, which is why I thought the preset was originally the issue but then I tried it manually with no preset applied and still couldnt use the trash icon to delete the watermark like I usually can.

Good morning @iamloco724 ,

Well, I can’t reproduce your issue with the same build:

Could you, please, provide us with more details (steps to reproduce, screenshots, image+sidecar)?

Thank you
Svetlana G.