Push plug-ins for Lightroom

As of today, the dpl plugins are installed the first time that dpl is launched. Sometimes or over the course of time, the plugins stop working properly.

I propose that DxO provide a means to reinstall the plugins manually or automatically as well as reliably.

When you say DPL plug-ins are you referring to Viewpoint and FilmPack, or are you referring to 3rd party plug-ins? If you meant Viewpoint and FilmPack, I have been using them both with PhotoLab Elite every since PL version 1 was released and continue to use them regularly with the most current build of PL2. I have never had the problem you mention. I run PhotoLab on the most current build of Windows 10. Could you supply more detail regarding the problem you are seeing?


Mark, every now and then, the Lightroom plug-ins cease to work and I found that they can be reinstalled with a series of non-user-friendly actions like finding the plug-ins, deleting them and editing aDPL preference file.

DxO could add a little something to DPL that makes sure that a) the right plug-ins are installed, b) Lightroom checks that they are or c) that the plug-ins can be reinstalled and/or reactivated manually without having to resort to rather nerdy actions.

You indicated DPL plug-ins in you earlier post rather than Lightroom, which is what confused me. I no longer use Lightroom, so I can’t comment on your issue.


…plug-ins installed by DxO PhotoLab that enable DxO PhotoLab to act as extended functionality in Lightroom, namely to send images from Lr to DPL and back…

I understand that noe, but it was not completely clear to me in your original post. Sorry to hear that it occasionally requites an annoying reset.


I can add my cent to this discussion. Here is the last problem I got with these “pushing” plugin. Aft many trials, I got discussion with Platypus. He tried to help me. But nothing went correctly.

Here is my case…
OUT OF the DxO importer/exporter plugin (dxo-importer-dpl3 and dxo-exporter-dpl3) that are systematically crashing.

HOW do I obtain this:

  • PL3 is not running.
  • In LR, I choose a RAW file that I want to send to PL3
  • I use the classic procedure.
  • I get vey shortly the old splash screen
  • And I get a crash with PL3 (which version?)

This doesn’t occur if PL3 RC1 is running.
In that case, picture is well sent to PL3 RC1

Can it be that I don’t have a good version of these plugin’s? Is there a possibility to load the correct plugin’s?

Since then, no solution and no reaction from DxO team

If you are referring to an issue you are having with a Photolab 3 beta, you should probably not be posting that question in this forum.

In Lightroom under plugins there are DXO importer and exporter plugins installed. I guess they refer to PL2 while you are apparently running PL3 beta RC 1. Sounds like some path/reference on your system is referring to PL2 for starting a process while when PL3 is open it picks up the running process on the system.

Thanks for you comment Floris. This exactly what I try to find. There is somewhere a file or process refering to PL2.

I had to reformat my PC and I installed W10 then Photolab3 (RC2 of October 19th).
The plug-in for Lightroom does not work.
I uninstalled and reinstalled PL3 twice without result.
Does anyone have an idea to solve this problem?
Thank you


Re-installing the DxO-to-Lightroom plug-in is covered in the support section here.

Hope this helps!

Thank you daveywilson.
I will try this and come back to give the result.


The export of DxO to Lightroom works.
However, the export of Lightroom to Dxo is not possible. In “Export to” of Lightroom this option does not exist.

You have to delete the plugins from within Lightroom first. Then try the “Export to DxO PhotoLab” option to trigger the installation.

Here’s a step-by-step that’s a bit easier to follow.

Thank you very much for your help.
I followed the indications given in the link above. It did not work.
From the beginning, when I want to export to Lightroom by clicking “Export to Lighroom” in the window that opens on the first line it says “Lightroom is not installed”.
The previous time I had export by clicking “Export to application” and then selected lightroom.exe in program files (W10).
I have erased all plug-ins in PL3 again. There was none in Lightroom.
I started a PL3 repair. The plug-ins have been reinstalled. But it always says"Lightroom is not installed" in Export to Lightroom.
Since PL3 the export runs to Lightroom but not from Lightroom to PL3. No plug-ins are installed on Lightroom.


It sounds like the entry in the Lightroom modul got corrupted somehow. Try this below. If this doesn’t work,you need to contact support and create a ticket.

  • Open C:\Users<user name>\AppData\Roaming\Adobe\Lightroom\Modules\dxo-exporter-dpl3.lrplugin\PluginData.lua

  • Check whether the third line says : dxoExecPath = “invalid”

  • If this is the case, replace “invalid” with “C:\Program Files\DxO\DxO PhotoLab 3\DxO.PhotoLab.exe” or whatever the dxo executable path might be (beware the double backslash)

  • Save

In the Lightroom module there is no directory “dxo-export-dpl3.lrplugin”.

Then the plug-in is not only not installed correctly, but not on your machine at all.

I recommend you put in a support ticket for help in performing a clean uninstall of DxO PhotoLab from your system, reboot, then reinstall PhotoLab from scratch. They’re support team is super fast & responsive from my experience, though being the weekend, you might not get a response until Monday.

There’s specific folders you need to manually delete upon uninstall, but I can’t recall the specifics at present, or I’d help you myself.

Best of luck with this!

Okay daveywilson. I’ll do that. Thank you again for your kindness.
Kind regards