PureRAW Global Sharpening not working?

I first noticed this while working on @Andreas_S photo:

P3130743.RW2 (18.8 MB)

Posted On this thread

The OP was a notification of artifacts associated with oversharpening using PR2. I ran my version of PR2 on his file and observed no such artifacts. A few days later I ran his file through PL5 and DID observe the artifacts that Andreas had mentioned. I then exported the file with the same settings in PL5 as PR2(with the exception that Global Sharpness was reduced to -0.50 and compared it with the PR2 export with GS set to on(= +1.00 in PL5). The artifacts were clearly there in the PL5 export but not in the PR2 export. I then exported a version from PL5 with the Lens Sharpness module deactivated and the result was identical to the PR2 export with GS set to On. Here is a screenshot comparing 4 versions of the shot in FastStone IV 7.6 at 700%. Clockwise from upper left: Original RW2 file, PL5 output with GS set to -0.5, PR2 output with GS set to On, and PL5 output with LS deactivated.

Please note that the output from PL5 with GS= -0.5 is much sharper than the other three.

Okay, now about this time @Marie responded that the lens module used for this file is too aggressive and will be fixed in a future update. So Andreas’s problem will be solved. All is okay now, right? Nope.

Now my problem; I tried the same experiment on some of my files and found the same result on each: PL5 version is much sharper than the PR2 version. On my version of PR2 the result is the same as PL5 with Lens Sharpness deactivated. I can only conclude that, on my version of PR2 Global Sharpness is not working.

I am a Beta-tester for PR2, but never thought to compare the output of PR2 to that of PL5 with identical settings while we were in Beta. Maybe we all just missed it? However, I can clearly see the oversharpening on Andreas’ version processed in his copy of PR2, so apparently his copy is working properly. I have tried uninstalling PR2, redownloading, and reinstalling three times, all with the same result Global Sharpness is not working.

I don’t know what else to try.

Here are a couple more screenshot comparisons in the same order as before.

Does anyone have any insight on this issue? It’s really bugging me.


I found the cause of and solution to this issue. I have a small SSD for my C-Drive. Programs(even those that are installed on my large HDD D-drive) constantly store useless(to me) data(log files, crash dumps, etc… sometimes even program components so you have to be careful) on the C-Drive in places like App Data and a few others. This includes DxO products. These are files that your disc-cleaning software never sees. I frequently need to find these places and clear them out of GBs worth of junk.

On one of these occasions, a couple months before I encountered this issue, I decided that I didn’t really need to have a lot of lens modules stored four different times when it is not much trouble to simply download each one as it is needed. I deleted all lens modules for PL, PR, VP and FP. For some odd reason, haste I guess, I deleted the entire folder for PR not just the modules. I caught the error before I emptied the trash, but thought: "Oh well, PR will just create a new folder when it sees that there isn’t one already there. So, I then forgot all about it.

Enter Andreas with his problem and then my problem ensued. After investigating this issue further, I realized that not just lens sharpness was involved. NONE of the lens corrections was working at all. Turns out that missing folder was the problem. When I checked there was no new folder. Instead there was just a single file. I don’t remember what it’s designation was. I then manually made a folder and labeled it “Modules” and put the existing file inside the folder. I tried PR again and it still wasn’t working, same problem.

I went back to the folder and removed that mysterious file to the trash and tried PR yet again. BINGO, it was working perfectly!

This seems to be specific for DPR on Windows. On my Mac, I deleted everything DPL, except for the application and the license file - and DPR seems to have recreated all those deleted folders and files again, without any other sign than asking for the modules again.

1 Like

Yes, I deleted everything but the license too, three times and that one folder was never recreated. I suspect that the mystery file that was left in place of the folder somehow tells PR not to recreate the folder and to not apply any Lens Corrections ever, on any file. I’m not sure why this would be the case. Maybe if someone wants to use some other program for lens corrections and just wants to use PR for Deep Prime and conversion to DNG this would be useful. I’m just guessing.