PureRAW Creating Blank DNG files?

Hi there, I’m trying out PureRAW with raw files from my Canon R5 and I’ve seemed to run into a weird bug and can’t find a work around. I can convert 1 or maybe 2 raw files, and view the results and everything looks good… but the next raw file(s) I think try to convert come out as a black.dng file. Once this happens, nothing I do will let me process a file and see the results again until I reboot my machine and then it seems to work again for 1 or 2 files before the cycle repeats.

These aren’t raw files I’ve edited in Lightroom or done anything to. They are basically straight out of camera. I’m using Windows Explorer to just drag and drop the raw file directly into the program.

Is anyone else seeing this issue? Thanks!

I also have this problem. It seems if Lightroom is open that PR will create a black blank DNG file.
I have found that if you close LR it will work correctly.

Got to say for most part love results in PR but the LR integration is very clunky!

1 Like

I am also having this problem. I contacted support and they quickly responded saying there might be issues on gaming systems where 3rd party apps try to optimize the graphics pipeline or display information on the screen. I rarely use my system for games, but I remembered that Steam is auto-loaded. I removed it and the problem seemed better, but now it’s back. After a reboot, images are processed properly, and then randomly, they start going black. When that happens, recovery is very difficult. I tried doing a right-click “Remove Photo” in PureRAW, but nothing happens. The black DNG still remains in the DxO subfolder. I then do a “Clear thumbnails” and re-drag the raw file. PureRAW just shows the black DNG again! I have to go into the DxO subfolder and explicitly remove the black DNG using Windows Explorer before I can proceed.

The workaround when PureRAW gets stuck on creating black DNGs is to go into the menu and select “File/Preferences” and change DeepPRIME acceleration to “CPU Only”. This always works at the price of being twice as slow on my system.

DxO needs to figure out what is causing the GPU processing conflict or at least detect it, and recover gracefully with an error message. Also, “Remove photo” should do the right thing and remove the bad DNG file.


I was having trouble figuring out what was triggering it but I’ll have to see if this helps with the issue for me too. I do like the results I’ve been getting but when this issue comes up, it’s so frustrating to get it to start working again. Thanks for the tip!

Same problem for me - might happen after a few pictures … All of a sudden you get an hardware (!) error related to the GPU ( I have a Radeon RX560) and then the processing of the remaining pictures in the batch becomes very very fast (just a few seconds compared to 35sec normal) and all resulting dng’s are black. If this error happended, even if you close PureRaw and restart it already the first picture aborts and is black again.

Exact same issue. So frustrating. I have since set to use CPU only and whilst taking longer I’m lucky to have AMD 5950x. My GPu is 3090 so it can’t be to do with being underpowered. Look forward to DXO getting it fixed aswell as supporting the song a1

1 Like

I downloaded V1.2 and the issues are still persistent.
Any idea when this problem will be fixed?

I have exact same setup and exact same problem

I too have and am having this issue. My workaround has been to delete the corrupted file from the drive it was saved to. Then choosing PRIME instead of DeepPRIME. Just learned that if you changed the preference from AUTO to CPU Only the same files will process at DeepPRIME but at a much slower pace. So I am confirming what others have written here. My GPU is a NVIDIA GeForce RTX 2070 Super. Would have thought this has enough power to process the RAW files in DxO PureRAW.

Any update on this? Still encountering this bug (version 1.2).

Has anybody found out what the problem is ? I have the software for about 2 month. Everything worked fine until 3 days ago. But now I got only black dng files. What does DXO say ?

Any update group???