Pure Raw broken since update

I downloaded and installed update this morning, 3/19/23, and now Pure Raw is unusable, just defaults to DXO website when trying to use. Any ideas?

Welcome to the forum @drdan_1

Have you tried to

  1. remove DPR as well as its plugins
  2. install DPR again

I’m not sure what you mean by this. Could you be more specific? Is it asking for your license key?

I have tried uninstalling, reinstalling. I didn’t remove plugins, however. Not sure how to do that.

When I open the app, it opens then just jumps straight to the DXO website so it is unusable. On the website it keeps offering to upgrade to DXO3. I was probably going to do this anyway at some point but I can’t imagine that they would pull something like this deliberately to force me to upgrade. No response so far from DXO on support request but has not been 24 hours.

DxO PureRAW does not automatically connect to the DxO website.

Are you talking about this screen?

If so, just tap the ESC key and it will disappear.

Or are you talking about this?

If so, this is a browser window so close your browser and PR2 is underneath it ready to go.

Mark, it is not supposed to automatically connect to website but it does. That’s what I mean by “broken”. Closing that browser window does NOT make Pure Raw ready to go. Any attempt to use DPR results in the website popping up.

Still unusable for me and support had still not responded.

Starting to get pretty irritated.

All this started immediately following the last DXO update I installed.