Problems working with NIK 6 as Plugin from Affinity Photo 2


I have a problem with NIK 6 and I hope that you can help.

I purchased and installed NIK Collection 6 today. I already worked with NIK 5. Using Mac OSX 13.3.1 (Venture) on a Mac mini M2 Pro, 32GB. Version 5 was fine!

When I start f.e. Color Efex Pro 6 as a native app, I am only offered “Save Preset” in the bottom right corner. The “Apply” button I am still used to from version 5 is missing. I’m able to save with cmd+s in this case, but it is unfamiliar. Is it supposed to be like this?

When I launch Color Efex Pro 6 as a plugin from Affinity Photo 2, the screen looks exactly as described above. The apply button is missing. I’m able call cmd+s and I also see the progress bar, however the plugin then hangs reproducibly after the progress bar has reached 100%. Then I can only cancel the plugin via “force quit”.

What am I doing wrong?

Thanks and best regards

I’m experiencing the same problem with Nik Collection 6.
Using Mac OSX Ventura 13.3.1 (a) on 2019 iMac w/ 8 cores and Radeon Pro 580X 8 GB graphics and 32 GB memory.

I purchased & installed it yesterday, and successfully used Color Efex Pro 6 one time.
However, last evening I updated from Affinity Photo V2 to Affinity Photo V2.1, and today all of the Nik Collection 6 plugins are missing the “Apply” button.
As described by @MartinHH without the “Apply” button available, I also observed that using Cmd+S to save caused Nik Collection 6 to become unresponsive, requiring me to use “Force Quit” to abort.

I’ve used Nik Collection 3, 4 & 5, and hope that a fix is forthcoming soon.
Please advise, thanks.

1 Like

nik 6 color Efex work fine with APv2, not talking about the v2.1 version, I haven’t installed it yet and glad I didn’t seeing people complaining of issues.

just took that screenshot, is that what you referring to?

revert to v2, if you still have the installation software, or ask Sherif to send you the v2 version, if you of course bought it from there website and not from Apple Store.

Yes, Nik Collection 6 works with previous AP versions, just not APV2.1.
In the Affinity Forum, it appears they’re aware of the issue, as well.
Here’s a screenshot I captured while using APV2.1, wherein the “Apply” button is missing:

I almost click update AP yesterday after reading what was new in v2.1. just happy I told myself wait a day or 2 and check the forum if anything comes up =/

I’ve found my original Affinity 2.0 installer so have reverted Affinity and that has restored the Nik 6 integration so I’ll stick with that until Affinity and/or DxO/Nik issue a solution.

1 Like

I’ve posted this on the Affinity forum too. Affinity just got back to say they are aware and are investigating the issue.

I have the same problem. It only happens with the latest Affinity 2.1 update. The older Affinity 2.0 worked fine. v2.1 also works with Nik 5. It is specific to those 2 versions. Unfortunately I don’t know how to roll back an Affinity release and having paid for Nik 6(and like it a lot!) I don’t want to revert to v5.

Yes, exactly. Thanks a lot!

Thanks a lot, Alan, good to read that!

Thanks a lot, Phil!

I experienced the same issue today. I had recently updated my Affinity Photo to v.2.1, and started trialling Nik 6 today.
I reported this on the Affinity Photo forum, and meanwhile I rolled back to Affinity Photo v.2.0.4, without uninstalling and reinstalling Nik6. My trial version of Nik 6 seems to be working fine now.

In this thread: V2.1.0 Affinity Photo breaks Nik Collection - V2 Bugs found on macOS - Affinity | Forum
it is mentioned that the Affinity Photo developers have been notified of the problem.

I just want to confirm that I also have the exact same problem that above posters have mentioned.
I’m on a M1 Mac, Ventura 13.3.1 using Affinity Photo 2.1.
My workaround is to export a temporary 16bit TIFF to Desktop and then do my edit in Color Efex and then save (Cmd+s) back to Desktop and then copy it back into the layer structure in Affinity Photo. This is a cumbersome process that I hope will be fixed soon!
Since the Save button is also missing in the stand-alone version of Color Efex (I haven’t tested other NIK software V.6 yet) I have a feeling this this problem is not entirely connected with Affinity Photo V.2.1 alone?

Thank you


1 Like

Good news! The latest Nik update to 6.1 now works with Affinity Photo 2.1.

I tried Viveza, Color Efex and Silver Efex and all work faultlessly so I’m assuming the others will too.


Alan - is 6.1 available publicly as yet?

Yes, it prompted me to upgrade last time I launched ColorEfex. I downloaded, uninstalled 6.0 and installed 6.1. The installer recognised Affiinity (v1.10, v2.0 and v2.1!) and when I tried 2.1 the plugins worked as expected.

I can confirm that Nik 6.1 works with Affinity Photo 2.1. I only tried CEP but Nik adjustments can now be saved.
Good and quick work!