Problems with NIK activation

I have DXO, had the program for years, then all of a sudden they block me and want me to pay for upgrade, where I agree it is not worth it, of all the subjects I only ever used two,
have sent 14 emails to them none have been replied to me, only from a robot, they want me to fill in a form which I did, still repeating the emails, can’t complain, can’t get in touch, as the email I did get was sorry don’t reply to emails as it could be. scam, will live with out DXO from now on

But you do still have the use of the version of DxO that you paid for. unlike Adobe and others, not paying for an upgrade doesn’t stop you from using it.

You got all point releases for free up until the new version came out. You surely don’t expect to get full version updates for ever as well do you? How would a company that did that survive with no ongoing revenue stream?


Hi @Elaine,
I’d like to better understand your point of view…
From your words, I guess you are (were?) a DxO loyal customer and you were part of the beta testers’ program for many years, right?

@StevenL, maybe @Elaine has noticed that DPL4 is not shown in the DxO shop under her login. According to @CaptainPO, this is normal if the license is a gift license. With this new policy, no DPL4 beta tester should be able to see DPL4.

Dear beta testers, can you see DPL4 when you log into ?

I’m not overly happy with DPL 4.1 and therefore reinstalled DPL 4.0.2 which would not have been possible without my time machine backup. One reason is that unused tools look like greyed out and are very hard to read. In 4.0.2, the open/close triangles are still there and comparatively visible.

I don’t like the new GUI (Graphical Use Inhibitor) design.

No, I can not see it

I can see my (bought) copy of DPL3, together with an upgrade offer to DPL4.

Steven, I was not a tester customer, I paid for the program, I have a down load ticket to prove it was paid at £49-00, al was going we’ll till my Mac crashed, I had to take it back to factory setting, losing my Dxo and many other programs, I have tried many to get reconnected but for some reason nobody seems to understand what I mean, on my lap top no problem, I have the full package on there, still use it, but I want my full package, back on the desk top, any more info please do ask
Best regards Elaine
paid 12/10/2018. cost £49-99

Hi elaine it’s better to pm to StefenL because it’s not wise to put this in open forum.
If you can’t pm , i can offer you to copy paste it in a pm to StevenL myself so you can delete the personal data. After that.

Regards Peter

Hello Peter
I have tried email but all it does it goes to automation not for anybody to see


HI Joanna
I do not have the copy I paid for, it as gone of my Mac I have the serial number but can’t add it, all I get it update, I have no reason to update as I had the copy, If I have the copy I would not be asking the questions Iam asking

Hello @Elaine,

You do not need to write an email just a direct message like this:

As your post contained personal info, I’ve modified it a bit to hide the personal info.

Svetlana G.

I have not got a version, that is why I am asking to get my version back, I am not expecting not to pay, as I have already paid, so don’t put in that league as I don’t want to pay, I have explained what as happened,

Best regards Elaine

So, in essence, all that is wrong is that you can’t reinstall DxO because you have reached your licence limit?

In order to reset your activation count, simply get in touch with DxO support, explain the situation and I’m sure they will be able to help.

@sgospodarenko is this something you can help with?

HI Joanna
I been wringing to Dxo, for the last two weeks, it was not till I fond this page, that I was getting any response of any body, I have not reached my limit, if I had it would not b working on my lap top every time I try to get help, all it says update, if that is so why is it working on my lap top no problem and not on desk top

If you have a time machine (or other) backup, you can copy the license folder to the rebuilt machine.

The files can be found in Macintosh HD > Library > Application Support > DxO Labs > License (or something of that kind)

Note: this fix does not work to transfer licenses between different computers.

You have installed it twice; once on your laptop and once on your desktop.

The copy on your laptop is still working because it is a perpetual licence and the will keep on working. You might get update reminders but those will not stop it from working.

As for the copy on your desktop, DxO’s activation servers still think you have it. This is not unusual - it happens whenever someone upgrades their computer. All you need to do is get in touch by Direct Message, as suggested by @sgospodarenko and get your licence count altered to compensate.

I dont have DXO only the free trail i have for 30 days, beofer it was called nik ware , had it for years and no trouble, till my mac crashed, desk top,

how can i copy the file from lap top to desk top

Good morning,

  • Only support team has the privilege to deal with the activation. So your suggestion to address the problem to the support team is the only one possible in this case.

Svetlana G.

1 Like

Dear @Elaine,

What message do you see when you try to activate the application on your desktop when you put your actual key?

Could you, please, make a screenshot and attach it here (just a warning message, no keys)?

P.S. One more, @Elaine you can also get the access to your purchase from your DxO Customer account at

And with all the problems of activation, please create a ticket here

Svetlana G.


Good question! After reviewing Elaine’s string of rather confusing posts I am starting to believe that she is referring to the Nik Collection and not PhotoLab. I’m guessing she may have downloaded the trial version of the Nik Collection 3 which overlaid her previous paid version of the Nik Collection 1 from 2018. That trial has apparently ended and she can no longer access her paid for version of Nik 1, and now she is being asked to pay for the upgrade.


1 Like