Problems with latest Windows 11

I’m using Windows 11 on my PC. Last night I had an update on Windows 11 to the latest version. (22H2) After that I have had several occasions when Photolab has stopped working. Only way to fix the problem is usually the task manager and kill the DXO PL program.
It looks like PL has a problem with the latest version of Windows.

Hi @TorsteinH

did you use the latest version of DPL also, and have you tried to reinstall DPL?



I just did the update to Windows 11 Pro 22H2 a few days back. So far DXO PhotoLab 5.5 has been running fine for me; no issues with freezing or anything else.

Just to add to the suggestion above - also check that you have updated your video card (GPU) drivers to the latest version.

I had the 2022-09 “update preview for .NET” show up as ready to download. Then yesterday the 22H2 update to Win 11 Pro took its place as ready to download. Today, Windows Update is back to showing only the .NET update preview. I think I’ll wait a couple of weeks to install either.

Sometimes something goes wrong when Windows installs an update. This happened to me recently: many of my background apps were silently crashing, disappearing from the taskbar. Ordinarily I’d suggest running “sfc /scannow” as administrator to make sure the update installed OK (this solved the problem for me) - but I remember reading that this tool can also become unreliable with a brand new update. A couple of extra reboots can make a difference, though. Also, everything should look good in your Windows Event Viewer system and application logs.

I don’t know, perhaps it had nothing to do with Windows. I looked at a directory with photos I had not worked with for several years and PL worked hard with index and render the files. After a while it stopped and hanged Now that I have been there a few times, everything works just fine.

I had forgotten all about it, anyway the problem is solved. But thanks for the suggestion anyway.