Problems printing from PL 6, Elite, last update, to printer Canon 8750

I have printed before with great success, but this time (after update?)it does not work - it printed half what I asked for - about A4 print, even it was written A3 PLUS (483 x 329) whatever I tryed to do and change in the settings - PL, or Canon printer it only printed about A4 size - I think I tryed everything in the settings to get it to work

It was urgent so I went to my - very old and discontinued - Nikon Capture software - and printed fine out here, but I am about to change pc.s to either W11 or Mac, so here the Nikon Capture will dissapear, and I need the PL6 Elite to function in print - any suggestions - as mentioned I think I have tryed everything in the settings ?

Do you remember what (how) you have set up the print module and leave a screenshot?

The set up in DXO (the set up in the printer = The same)

The result in the printing

I enlarged & exported a pic as TIFF / 13x19 inch = A3+ and send it to PL6’s print module. Your printer settings look alright (checked with settings for my Epson printer).

As long you have chosen the correct paper size in the printer driver it should work and not only print “half”.

to add
The manual for your printer mentions the suitable print area.
Please check if you can print borderless as indicated in your screenshot.

I have a Canon Pro-1000 A2 printer and use Canon’s own printing software. It does an amazing job and gives me full and precise control of placement and layout. All I do is export a correctly sized TIF from PL and load it into the Canon software.

I also have a Canon printer. However it’s not a Prograf and therefore can’t be used with the Canon software you should be using. afaik the i8750 doesn’t work with the pro prinitng software either.

Wolfgang= Thank You, and yes I did, and I also can print borderless from the very old and discontinued Nikon Capture.

The print setting in Canon is the same as I have always done - be it print from Nikon Capture or Photoshop - the Canon printer is set correct up, but there is something missing from PL.s software here.
I mentioned that I printed fine out earlier, but it was an A4-print= This is the first time I print from PL (6 Elite) in A3 plus (483 x 329), but this PL should be my furture in printing :wink:

Thank You Joanna, but I think Chakonari wrote it - thank You Chakonari.

This is funny - there must be a problem in PL, since I can do it with the very old and discontinued Nikon Capture ?

Reading this I have found I had the same issue. I use PL7 and have a Canon Pro 300 as well as the Canon printing software and it drove me nuts after using up a lot of paper. Problem solved by connecting the printer directly via cable and not using wireless. I would end up with a poor connection and with printing large files the wireless would slow down and the buffer in the printer would not get enough information and then after a while stop printing. If you are not connected directly then try this. Also, I learned for larger files this is the preferred way as noted by Canon support (but not noted in their user guides). Never had an issue since.

Hope this helps

1 Like

Thank You, Andre. this is interesting - hope they (PL) read here ?

but I am wired !!! and has always been with both my printers (Canon 8750 and 6250 - later going for the Canon A2-printer)

Otherwise - if not wired - I do not think I could print with the very old and discontinued Nikon Capture, which works like a charm for printning ,

…but Nikon Capture (they should have updated it, but they did not) will nok work with Mac or W11, whatever I choose for desktop next time (I have a Mac for laptop, but there is a learning curve, so I am not sure which to choose :wink: ) !!!

If this is not solved the PL is not the future for me, sorry to say, because I really love the interface.

I have just send the DXO support a link to this thread.

I use the Canon 8750 with Photolab 7 for my printing but I use PL7 to carry out soft proofing then send the resulting virtual copy to Qimage for printing. The website is Qimage Ultimate - The Ultimate in Batch Photo Printing Software. Although this is another expense I have saved a lot of paper since using Qimage & have no problems printing up to A3+ using this software. You can download a 14 day free trial from the download page on their website.

… there have been reports about the “air print driver” causing problems
(possibly also interfere with print size)

@mujabad is also using QImage (on Mac)

I’m using PL6 on Win11 and having problems with the margin settings when printing to a Canon Pro-200 wirelessly. The Canon is capable of borderless printing and I have set its driver to borderless however the DXO Print dialogue box will not allow me to set the borders to zero, it also seems impossible to accurately set the image size as the actual print dimensions have no correlation to the DXO dimensions. I’m printing wirelessly but it should be possible to see the dimensions and borders in the dialogue boxes prior to printing even without the printer switched on so I can’t see that the wireless transmission would be an issue. I’ve seen a number of threads on this subject going back many versions of DXO is it ever going to be resolved?

With the regular Canon driver (not Print Studio Pro) under Windows, I need to open the printer settings from within PhotoLab’s print window and then turn on the borderless setting to be able to set the borders to 0.

1 Like

Thank You, I have copied the link from You and saved it, but for the time being I just use the very old Nikon Capture - it works like a charm.

As mentioned I send a link from this thread to the support, - everything is mentioned here so fine, but they wanted more, so they are not so interested, sorry to say.

I also had troubles setting it to zero, but I succeed at last - do not remember, what I did :wink:

Yes, they are not so interested in resolving this problem, sorry to say. Perhaps it need a lot of IT-knowledge, they do not have (printing has long time been a problem, but Nikon Capture (It wil say it was the Nik software - they who created the Nik software we also can use here) …solved it LONG TIME AGO.

Yes, now I remember - I solved it the same way.

I am wired.