Problems opening Silver efx pro & viveza from Lightroom

Apple M1 16gb, Montery 12.4, Adobe M1 Native. Nik 4
If I launch either of the above from Lightroom Lightroom becomes unresponsive and I have to force quit it.
The Nik Software loads, I make my adjustments and save the file. Back in Lightroom, when I click the image I get the message “loading” but the image never loads. I have to force quit Lightroom.
This on a fresh install of all the software on the M1 mini, including MacOs.

Anyone else have this issue? Or can offer guidance?


1 Like

Have you tried running Lightroom with Rosetta?

Silver Efex and Viveza are apps made for Intel processors and the exchange might be better if everything used Rosetta.

Thanks for the suggestion. No I haven’t done so. I’ll give it a go and see what happens.

I tried it. It makes no difference. So I have Nik 4, the sharpening plugins don’t work M1 Native, Viveza & SFX pro are unusable. Can’t believe this software has actually been released for use.
SFX pro works standalone, so I’ll use it that way. I’ll give up using Viveza.
I’ve been using the Nik plugins as a part of my workflow for a long time. Have to say I’m sorry that DXO now has them. They are using them as a cash cow, which would be sort of OK if the software they released actually worked.
No chance of an upgrade to Nik 5 for me.

Someone recently reported that Lightroom has a bug affecting interoperability with Nik. It isn’t clear to me that this has been ruled out in your case. I suggest opening a ticket with if you haven’t already. Or with Adobe.

The interoperability works perfectly except for SFX Pro and Viveza. I don’t see this as an Adobe issue, if it was all the plugins would not work.

Hello. I’m on an M1 Mac also, and Viveza and Silver Efex both work as expected.

Are you running Nik Collection version 4.3.4? There’s a fix listed for that version described in the release notes as “Bug Fix: Nik Collection plugins freeze when applying a filter or a preset during image loading.”

My Viveza and Silver Efex apps show as version 5.0.4 (4.3.4). If there’s some other setting I can check that might help you, please let me know.

I say all that based on what others have been reporting here in the forum for some time now. With Nik Collection 4 those two plugins have changed. Their binaries have even moved to another folder. This has caused incompatibilities that Adobe has had to address. AFAIK they have been addressed, but I don’t know exactly how.

Thanks for the helpful reply. I’m running the latest version downloaded from DXO.

I’m afraid this is not helpful. Which version of Adobe has addressed the issues? Is it both PS and Lightroom? Does the latest version have the fixes? What was the nature of the problem?
I’m running the latest versions of all the software, freshly downloaded with a fresh install of macOS. Surely the latest versions are correct?