Problems in PL 6

I have a couple of questions/problems/issues and need help:

  1. I created a significant number of edited images, listed as “projects” in the left hand panel of DXO PL 5. The names I gave them show up in PL 6 but not the images. Some of the original images were DNG files that were in LR Classic with the actual images stored on my RAID drive. I’ve gone back into LR to try to bring them into PL 6 but neither the DXO version nor the original DNG open. I get the message that the camera used isn’t supported by DXO PL, which it certainly is. This is occurring with multiple camera models, all recognized by PL5. What should I do?

  2. As noted above, I store my images on a RAID drive. I recently returned from a trip and have thousands on images on a EHD. I want to create folders on my RAID drive so that I can move images edited in PL into those folders. When I look at the left hand panel of the Photo Library in PL I see the name of my RAID Drive (My Book Duo) but it has no arrow and can’t be opened there. No problem opening it in Finder or LR. Please tell me what to do here.

Thanks! Stephanie

What version of MacOS are you using? Any other information might be helpful - but I think you should open a ticket at for deeper troubleshooting on your computer.

I use Monterey. I’ve tried rebooting. I am opening a support ticket but thought folks here might have a quick answer.

Let’s assume you have, on your EHD, a folder “CURRENT” (or whatever name it has) above the new folders you’ll create. Drag “CURRENT” to the Finder sidebar and check if you can then access your stuff.

I took an empty folder above the new folders I want to create and copied it from my RAID drive to Favorites in Finder. When I then open PL it’s there in Favorites but even though it has other empty folders in it on the RAID drive that I see in the Finder, in PL it can’t be opened and has no downward arrow. It does have a tiny red dot in the lower right corner of the folder. I don’t know what the red dot means. The folder can’t be moved or deleted from PL but was removed from PL when I deleted the folder from Finder. I remain mystified…

Hi @Stephanie ,
is it like described here "The folder (FOLDER) can’t be opened because you don’t have permission to see its contents." on MacOS SMB clients - NetApp Knowledge Base

The red dot only appeared in Finder but not in PL. I can open that RAID drive in all other programs (Photo Mechanic etc). I’m running Photo Mechanic, where the drive opens at the same time as PL but it can’t be opened in PL. It can be opened in Finder and all files are there, as they are in Photo Mechanic. Hope that’s clear. Stephanie

1 Like

Hello there

Have you verified that PL 6 do have access to external drives, files and folders?

Here’s some guidance.


Of course! That was it. I’d completely forgotten to change the Privacy settings!

1 Like

Great to hear you solved it!