Problem with Trial Nik DxO

I purchased Nik Software (pre DxO) and then downloaded free trial Nik collection DxO and I made sure that it didn’t override my old version which I still have and use because I decided not to purchase Nik collection DxO.
But I cannot get rid (i.e. delete) DxO. I’ve tried to ‘uninstall’ it from the ‘Download’ but it doesn’t work - there is a block on it.

Whenever I have a file and expect it to open in Photo Shop as it used to do I keep getting the drop down box inviting me to purchase it.
It is causing interruptions to my work flow.
I think this is not right as it is an infringement of my legitimately acquired software.
I had considered purchasing Nik DxO but this problem has made me have second thoughts about the integrity of the company.

I would be grateful if someone could help me put this right.

@Veronique, what OS are you on? Windows? macOS?

I must admit, that I have purchased the Nik Collection three times now. Once when owned by Nik Software (this was very expensive at over $400), then once when owned by Google (this was cheaper at maybe $80) and finally when owned by Dxo (maybe approx $125). I bought myself a new editing PC installed my software (Lightroom at the time) and installed Nik (the Google version). When the software went to the Web to verify the licence key it obviously failed due to the change of ownership. Then I had to buy it again from DxO, which was an annoyance at the time. On the plus side I did discover how great Dxo Photo Lab is and also managed to ditch Lightroom (something I have been looking to do for years). I now use Exposure X5 as my asset management software and Dxo as the editing application (Exposure X5 is similar to Lightroom, but Dxo does a much, much better job of editing raw files).

This does not help with your problem, but I do sympathise with your struggle.

Thank you for your attention here is the information you asked for:
Mac OS = High Sierra v 10.13.6
Could NxO be imbedded somewhere in my computer that is not allowing me to delete it?

Okay, let’s see.

Note: I have no idea where pre-DxO Nik installed its stuff.

I know that DxO’s Nik puts things all over the place. I ran “FileWatcher” during installation on my Mac (Mojave) and during first use of the apps. I got two tables with close to 10’000 rows that I filtered in order to get rid of things that seemed to not be part of the installation. Please note that the lists might not be precise and comprehensive.
Here’s what I got: (36.0 KB) (“macadmin” is the name of my user with admin rights, replace it with whatever you use)

Be sure to have a backup (Time Machine, Carbon Copy Clone etc.) before you start deleting things, the risk of which is yours and yours alone.

Thank you for your advice.
I didn’t use any of the methods you suggested but I’m grateful for the trouble you took in trying to help me.
After yet another attempt to get rid of the trial version of Nik DxO I have now managed to rid myself of it and the problems it was causing me since the trial period ran out.
So I am now continuing to use the Nik software collection I have had since 2014.