Problem with Lumix G9 files, sometimes supported, sometimes not supported

Hi all,

DxO Photolab is supposed to support Lumix G9 raw files. It does, but not all the times…:disappointed_relieved:. Sometimes, in a given folder, all raw images are considered as not supported. In another folder, everything is normal. What a strange behavior !

Thanks in advance for your help


Hello @Jeanlx,

Well, Lumix G9 is supported by the latest version of Photolab.

  • If you move these files to a new folder through the Windows explorer for example, and then open PL and browse this new folder, are the images supported?
    If still not, I need an example of the image file for the test (which is displayed as not supported).

Thank you
Svetlana G.

Hello Svetlana,

Thanks for your concern.

I copied a non recognized image to a new folder on my iMac and then bang ! it’s now recognized.

So far so good, what could I do to definitely fix the problem ?



Then it’s definitely a problem with your database.
And here it depends on how the current db is important for you.

  • If you do not work with the projects and all your corrected images have sidecars, then the database can be just removed and you will start a new one.
  • If you work with projects or do not store the corrections in the sidecars then the only way to fix the issue is the one I suggested in the first post.

Svetlana G.

Thanks Svetlana. I do not use projects and my images do have sidecars. Now how to remove the database ? It’s not immediately visible in the menu, and right clicking and deleting each project is rather tedious…

Thanks in advance


You can find it here - ./Users/user/Library/DxO PhotoLab v1/

Svetlana G.

1 Like

Thanks a lot, problem quickly solved, thanks to your dedication Svetlana.



At your pleasure :slight_smile: