Problem with crop tool

I realized that if you switch off crop tool in the tool tab and click on the crop tool on top there are no guides displayed for full picture. This mean that you need to use mouse to crop the image.

If you have crop tool to on then you get the guides and you can easily crop in on one or two edges.

For me it would be great to have the guides always, even if crop tool is off because if I apply crop with top button it anyhow need to be switched on to be effective!

p.s.: All my other RAW converter/editors do show the guides always, therefore I am always confused with PL3.

Not sure what you mean, in PL3 the grid show up when I click the crop icon on top tool bar, I never used the one in the palette which turn “on” automatically when I use the icon on top bar.
If you turn it off manually in the palette, why would it turn on automatically? You just told him to be off.

I used to have the palette switch off by default for JPEG and TIFF because I didn’t want any crop adjustment automatically applied. However, when I select the crop tool above the preview, it surprises me that the selection box doesn’t turn on. I inquired about it three times since 2016 via support and never got a reply from DxO. I can accept that the behavior is as designed, but found it very confusing and believe it can be better implemented.

That’s easily fixed, Franz: You can set the Crop tool (in the palette) “On” - and save that state to your default Preset (the one used by PL when it encounters a new image - - See Application Preferences).

Then, whenever you activate Crop mode via the top toolbar, it will display the guides.

John M


It’s not a problem but the expected behavior and @mikerofoto kindly explained why. Enabling the tool does not switch on the palette automatically, so if you want to see the crop frame you should enable the palette as well.

Svetlana G.