Problem running batch exports

Hello. Does anyone have issues with large batch exports (i.e 100s + deep prime). I put these files into timelapse images.

I’m trying to export to 16:9 (3840 long side) and it seems DXO doesn’t like to do that.

When I try to do the large batch export, I tend to get the ‘Unknown Error’ and :exclamation:
Small batches sometimes work but more often than not I will still get an error.
It doesn’t seem reasonable for my workflow to export one by one for 100s of files
I’ve included an image of what it looks like for one of my failed exports.

I am using DXO PL5 v5.4 build 4765. I am running a Ryzen5 2600, Radeon RX570 4GB with 16GB RAM.

Do you export the files to a local drive or over the network?
Does it work properly if you do the same export but in a lower resolution?

Hi @kevinsim
nice to meet you here.
I have just started a test to check if it’s possible with my old core i7-3770 / 32 GB Win 10 machine, DXO same version like yours
I took 334 Raw’s in orf Format, assigned a b&w preset and also Deep prime.
I’ve started and till now it’s running without problems.
The CPU is at 100% but if the power doesn’t go out DXO will probably finish at some point.
Normally I wouldn’t do this on my windows machine, but for testing purpose it’s very funny.

And I can still work with the system for browsing, email, and working with an excel chart

best regards


1 Like

What I noticed during the old horse is running is that DXO doesn’t handle CPU and processes not very well.
Like I said, during the export is still working I can also work without any delay in Excel, Outlook, Edge and my banking software. But if I choose another photo in the filmstrip the photo needs more than 2 minutes to show the edit view.
And yes, the Enable OpenCL isn’t set, but the cores are adressed.
Because I’m not so familiar with this technical deep inside stuff take it only as a note.

I think i will stop the batch process in a few minutes, because I need the horsepower for some work and at the moment there are 137 photos processed

best regards


1 Like

Hi Guenterm.

I recently went to update my driver for my Radeon RX570. It seems to work a little better but still running into issues with small batches. The most I’ve done is up to 50.

I did try a cpu only process and it seemed to work OK but then it really does take a long time. After updating the gpu driver, and enabling that, it is faster but still the issues arise. I took a shot of the export summaries to show what I’m getting. I think it’s interesting that you seem to be exporting to full size with no issues. I am exporting down to smaller pixels and still running into issues. I shoot with an R5 (8192 long side) and am exporting these to 3840 long side and also cropped to 16:9. These aren’t huge files imo.

Files are exported to my storage drive. My c:\ is an SSD and my D:\ where my photos are all stored are on a SATA.

And if you export to disk C, you have the same problems ?

Hi Kevin and welcome. Are you attempting to use the RX570 for GPU acceleration? If so DxO recommends RX580 or better. I think that the 570 will still work but may require THIS HACK for it to be recognized.

1 Like

Hi Franky,

I don’t think that’s important to which drive the files will be exported because his problem maybe come from the graphic card, the gpu acceleration or something which is described by Marks link to the hack.
I don’t have any problems exporting to my NAS, or an external USB Stick or SD Card.
Maybe @kevinsim can configure something in the driversettings of the RX570 for more conservative handling, or switch the DeepPrime acceleration settings from Auto to one of the possible manual settings. I don’t know if he has the possibilty for AMD onBoardGraphic or so. Just for testing to check if the problem is the RX570 GPU.

Thanks rrblint.

After I updated my driver, I am able to select the RX570 for the gpu processing. But I do not know if the ‘hack’ is still required.

I’m curious how many folks are running better than the ‘baseline’ recommended RX580.

Hi Franky.

I just did a test with a batch of 10.

Export to c:, no edits other than horizon, downsized to 2048 long side. No issues.

Export to c:, horizon + DeepPrime, downsized to 3840 long side. Only 1 out of 10 was successfully exported. The error says ‘Save has failed. Internal error. (Correction failed on the execute stage)’

So in classical testing you made one little failure :grinning:…you are changing 2 parameters.
You changed the long side value and you added DeepPrime.

What occurs if you change from DeepPrime to Prime without changing other parameters


Well you’re right although I am seeing more so the pattern of errors arising with deepprime and batch exports. Single exports seem to be ok.

Which led me to try switching the simultaneous processing from the recommended two down to one. It worked better in a batch of 32 files, with only one error encountered.

Good morning
Only for checking if it’s the graphic adapter and/or the driver with it’s settings could you set the acceleration in DXO from Auto or Gpu to CPU only and switch back simultaneous processing to value of 2?

happy testing