Problem printing to a Canon printer

My Epson P600 stopped working and I have just replaced it with a Canon PRO-300. The first print I tried on the Canon was directly from PL4, the way I have been printing for ages. But when the print emerged, though the colours were pefect, the image was highly pixellated - maybe 2 or 3 pixels per mm. It is as though PL sent a low-resolution image to the printer. It was an uncropped 20 megapixel image and I was printing to A3, so there should have been plenty of resolution. The workaround was to export to a full-size TIFF and then print that with the Canon printer utility, which worked perfectly.

I cannot work out what settings could have been wrong. Does anyone have any ideas?

I think I have the same problem described by Roger, except I am using a Pro-10, the predecessor of the PRO-300.
I took my file to NX Studio and it printed OK.
I reloaded DXO PL4 and Canon’s Drivers. No change.
Never had this problem before the last 4-5 days.

Good morning guys,

Thank you for the info. We have similar tickets in the Could you, please, also create your tickets there - it is the best way to investigate and fix the issue (as additional info can be requested and probably a test build provided)?

Thank you,
Svetlana G.

I am having the same problem with my Canon Pro-100S. I have wasted several sheets of expensive A3 paper, not to mention the ink, with no luck. I will raise a ticket as suggested above by the staff member.

Maybe the program took the thumbnail in stead of the real image.


1 Like

I have encountered the following problem with PL4. Previously I have used PL3 with a Canon P600, printing many A3+ prints with only minor irritations. I have just updated to PL4 and found at first that diagonal lines in A3+ prints had a jagged edge as if there was pixillation taking place (maybe 8X8 pixels) . The print was un-cropped at 24Mp. Further experimentation showed that this was also present in A4 prints but not visible in A6 (but probably present). Printing to a Canon laser printer at A4 showed the same phenomena as did printing to PDF and to Microsoft XPS. However exporting as lossless TIFF and printing with PL3 and with Canon DPP showed clean edges at A3+. Printer drivers and programs are up to date.

An irritating problem but with work arounds.

I also find that PL3 and PL4 do not take all the printer driver settings over – particularly orientation and borderless.

I am thinking this is something that has arisen in build 4.2 - the last images I printed were around Christmas when the build was 4.1.1. I’m considering installing the previous build as a temporary measure. Although I have raised a ticket about this, if it takes some time to find and fix I will have problems because I have orders for prints.

Hello guys,

I’m back with the good news - the issue has been fixed and will be delivered with PL4.2.1 this week.

Svetlana G.

Thanks for the update. I’ll be looking for the 4.2.1
I just uninstalled 4.2 in preparation for reloading 4.1.
I’ll just wait for the new release. Glad to see your have resolved the issue.
Thanks again.

1 Like

I have now uploaded the new version and it prints fine.
I am a happy camper again.
Thanks for your efforts to get this resolved for those of us who use the affected Canon printers.

1 Like

I have just downloaded and installed DXO PL 5.0.1 and have encountered the following problem.

Colour of print does not match the screen – magenta shift, too dark, and possibly too contrasty.

Printing of same file via Canon DPP 4.15 gives a normal print matching the screen. Screen is calibrated. Canon colour management was using the same profile as DXO

Exporting the file from DXO PL 5.0.1 as a TIFF gives a normal picture on screen (using IrfanView) matching the one in DXO.

Printing from DXO PL 5.0.1 using printer control of colour management gives an acceptable but not “perfect” print.

DXO PL 5.0 gave no problems and printing was the same as PL 4

The printer (Epson P600) is not at fault.
The main part of DXO PL is not at fault.
DXO PL 5.0.1 colour management is not functioning correctly perhaps not reading the .ICC file

Can you help here?

Good morning,

Thank you for the report. We are aware of this problem and working on it.

Svetlana G.