Prime Noise Reduction

I just received a sale notice for the Nik Collection and wanted to trial them before I decided. I had done so before and not been impressed enough to spend $150 for the apps but the sale price was very appealing. Since I had already trial-ed the Nik Collection some months ago Dxo suggested that I download Dxo 2 and the Nik stuff to a new computer and use that for the evaluation.

I did that, and copied some low light photos to see what Nik might give me above Prime NR but, for some reason, the Dxo trial would not enable the Prime NR button so I was never able to use the same machine to compete the Nik Dfine 2 against Prime. The question is, why was the Prime button not enabled.

I was using a raw image (an Olympus ORF file from the E-M1 Mk II) and Dxo has recognized those images for years now. Everything else in the Dxo “trial” worked so why would the Prime button not be enabled? I am puzzled and wonder what I am missing.

Hi, Mike. Nik 2 is bundled with PhotoLab 2 Essential edition - you need the Elite upgrade in order to use PRIME NR. I’m guessing you installed the Essential edition with Nik Collection 2, and that’s why PRIME is not available. As I recall, ClearView Plus will also be unavailable in that case. Does that help?

So that is very interesting.

I downloaded the trial for one of my MacBook Pros and, sure enough, it downloaded the Essentials version. Thank you for that. I have been using Dxo for so long now (I started back on Optics Pro 5 or something) that I no longer even thought about anything other than the Elite version and I am not sure I ever would have thought to look at the version when the app starts.

The question, then, is why did the download only give me the Essentials version and not the Elite. I looked for some way to convert this Essentials trial to the Elite version but could not find any. Of course the whole purpose of this was to see how the new Nik stuff worked, and that works fine with the Essentials, but it would be nice to compare the Nik Dfine functionality against the Prime NR.


Among the things I forgot was that my Elite version can be activated on multiple computers so I just logged into my account, downloaded the latest version and licensed it on the new MacBook Pro. That solved the problem since the license converted the Essentials version to Elite, but it does make me wonder why Dxo is only offering the Essentials version as a trial. It seems to me that they are purposefully preventing new users from seeing how well things like Prime NR works and losing sales. But then again what do I know about marketing? Fortunately, nothing.

Thanks again for your help.

Wrong :sunglasses:
The trial version (new major release or first installation) proposes only the Elite version.
But In your case, PhotoLab Essential is installed from Nik by DxO setup file.


I don’t understand what you are saying here

PhotoLab Essential is installed from Nik by DxO setup file.

I navigated to the Dxo website and downloaded the trial on one of my MacBook Pros. That computer had the Elite version of PhotoLab 1 on it but no version of PhotoLab 2 so why would the website have had the trial open in Essentials mode? Are you saying it is because the Nik stuff was installed? If so, why would that control what version of PhotoLab was installed?

What am I missing here?

If I understood, by downloading Nik 2 by Dxo setup file, you have access to the essential version of PhotoLab.
You have a 30days trial period from both Nik and DPL … but Essential.
To try DPL full access, Elite with FilmPack and ViewPoint, you must to dowloading DPL from the PhotoLab page
Note your 30 days period is initiated by the first installation.

I hope my meaning is clear :slightly_smiling_face:


Yes, but the link you provided is where I downloaded it from initially. I suppose I downloaded the Nik stuff first, and installed it, but I then went to the Dxo webpage to download PhotoLab 2.

In any case I ended up downloading the current Elite version from my Dxo account and since I have an Elite license I am allowed to activate 3 copies. I have activated the one on this new MBP and it is working, but it seems a bit odd to me how this worked out.

Maybe you’ve enabled this DPL2 Essential licence.
In this cas, you no longer have access to the trial period.