PLv6 Bug: Distortion / Constrain to image ... Incorrectly set by partial preset

I’ve encountered a bug that appears to be related to recent inclusion of ability to determine whether, or not, distortion correction is constrained to the image.

1. Background;

I have a partial preset that changes Color Rendering to Category = Camera Body, and Rendering = DxO ONE … because I particularly like this rendering, as an alternative to camera-generic.

However, I noticed, on applying this partial preset, that some degree of image distortion correction was also being changed … without direction for such a change being any part of the partial preset.

2. Unexpected result (aka, a bug ?);

Note the Constrain to Image setting (for the Distortion correction);

3. Investigation results;

With a bit of digging around, I found that the binary-state (true/false) of the sidecar/.dop entry that corresponds to Distortion / Constrain to Image is being flipped - despite there being no such instruction in the partial-preset file … as seen here;

  • BEFORE partial preset applied; image
    == image

  • AFTER partial preset applied; image
    == image


I suspect this is an internal logic bug resulting from “back-to-front” interpretation of the sidecar/.dop file setting … That is,

  • For, image (False), image

  • And, image (True), image

So, it’s not surprising that internal logic confusion is the end result !

@Cecile-C : Can this please be added to the list of “Fix as soon as possible” bugs.

Edit: Note that this bug is not specifically related to the partial preset mentioned above … I’m seeing the same result (wrong setting being applied to Distortion / Constrain to Image) for all partial presets.

@John-M I haven’t added your partial preset to mine yet but I tried some of my ‘Partial’ presets on an image which only had ‘Distortion’ set and the ‘Constrain to image’ unset/reset and nothing happened to that field.

I did then use a preset I had created some time ago which I titled ‘All off Partial’ and it set that flag while turning off all the settings!?

I then tried my ‘All off Normal’ and that turned on the ‘Constrain to image’ and ‘Keep aspect ratio’ while turning off all other settings!

So I need to correct those two presets but cannot repeat with my own ‘Partial’ presets (yet) but will add yours to my presets after breakfast and test.

Tested all presets included in DPL6 on macOS and only the following changed crop and distortion settings:

  • 1 - DxO Standard
  • 2 - DxO Optical Corrections only
  • 3 - No correction

The attached preset of yours is really quite simple and should not change crop and distortion settings:

Preset = {
Settings = {
Base = {
ColorRenderingActive = true,
ColorRenderingType = "DxOONE",
Overrides = {
Version = "17.0",
Version = "11.0",

But you suspect the “DxO One” color rendering to be the cause of the change. Let’s see:
I applied a few different color renderings and none of them changed crop and distortion settings…
BUT: Saving the settings as a new preset did and I had to edit the preset to make it behave.
You can test the whole lot with these presets, they worked on my Mac.

Absolute preset to start with:
A1 - preset.preset (10.2 KB)

Partial preset that sets rendering to DxO One
P0 - preset.preset (1.3 KB)
Looking into this preset reveals a completely different bunch of lines :exploding_head:
Note that @John-M’s preset has two distinctly different version numbers. I suppose that the preset has to be reworked in DPL6. Dragging along presets from older DPLs can have adverse effects.

Imo, the bug is in the creation of a new preset from current settings. Somehow, crop and distortion settings are changed to their default settings…which is NOT what we want.

1 Like

@John-M your preset certainly set ‘Constrain to image’ when applied but

@platypus when I applied your presets to one image with A1 and another with P0 then nothing untoward happens.

When I applied them one after another to an image where I had turned off all edits and had modified that preset such that ‘Constrain’ had been deselected before the preset was created then ‘Constrain’ remained unset!?

When I used the one that sets ‘Constrain’ and applied A0 then the field was reset and applying P1 still left it unset!?

No, I didn’t intend to suggest that this setting for Color Rendering is causing the fault - - only that a preset as simple as that example is capable of causing an unexpected setting to be applied to the image.

Yes, I reckon it’s something along those lines; - whereby, if an explicit setting is not applied by the partial-preset for Distortion / Constrain to Image then the default setting is applied instead … which is precisely the case for my simple example partial-preset … but is certainly NOT what we want.

There have been a few confusions related to this new ability to apply a setting for Distortion / Constrain to Image - including its original default being the opposite to that which was applied before this setting was exposed for user selection … and I strongly suspect these confusions are due to the “contrary nature” of the setting as it appears in the UI versus how its stored in a preset file.

That is,

  • For, image (False), image
    – False = True
  • And, image (True), image
    – True = False

A1 set distortion (and crop) to unconstrained and P0 is built to leave these alone.

Yes, but the new setting can bring parts of the original image content back into a crop, specially if the capture was very tightly taken. A few actions revert settings to their default and we have to watch carefully what is happening when we use the perspective, distortion and crop tools.

I’d prefer an unconstrained crop ratio, but DPL often pushes that setting back. :stuck_out_tongue:

@platypus and that is what happens with a new directory with No DOPs

  1. After discovery by PL6.7.0

  2. After A1

  3. After P0

Something else is needed

  1. After my Normal(1) which doesn’t set ‘Constrain …’ but resets all other edits
  2. After A1
  3. After P0

To avoid any & all confusion related to contents of user-created partial presets (including mine, as reported above) - this bug/fault can be confirmed using DxO-supplied presets.

Set-up an image with Distortion / Constrain to Image set as; image (Unconstrained )

  • and then apply either one of DxO’s 3 - Neutral Colors OR 4 - Black & White presets

  • the result for Distortion / Constrain to Image will become image (Constrained)
    – despite neither of those presets containing any setting whatsoever for Constrain to Image … which, internally, within the sidecar/.dop file, is defined via: DistortionAnamorphosisKeepEntireImage

Note: Testing by Platypus confirms that this same (faulty) behaviour does NOT exist for the Mac version - It seems to be an issue specific to the Win-version.


@John-M Yes if you do the test you identified then ‘Constrain…’ is set.

Possibly even more interesting is if you use 5 - No correction for which I can find no physical representation in the presets it will turn off ‘Distortion’ but set ‘Constrain …’ on!

Hence, it appears that there is some inbuilt settings which are being applied and could well upset users presets!

1 Like

For the technically interested: This is what the presets (DxO Standard and No Correction) look like on Mac regarding crop and distortion settings. Some of the values differ (check line 92) - even though they could be the same…which means that applying a different preset could possibly change a setting, even if it is meant to not do it.

1 Like

@platypus I have never been able to find ‘5 - No correction’!?

@John-M I suspect, as I believe you do, that, either deliberately or accidentally, there are hidden settings within DxPL!

Only DxO know what and why?

In the meantime I developed some (P)artial presets for ‘Distortion’ to add to my collection


which are here if anyone wants to use any of them

D - (2.4 KB)

@BHAYT, macOS applications are folders with the extension “.app”, which makes macOS display that folder as an application. Looking into the DPL6 app/folder, we can get to all the built-in presets:

The supplementary DNG preset is not shown in DPL either. Secret presets on Mac too :gift:

@platypus on Windows the DxO supplied presets are held as “.preset” files just like user and DxO presets in the standard directory C:\Users\Bryan Thomas\AppData\Local\DxO\DxO PhotoLab 6\Presets and in my case in a backup directory where I can develop new Partial presets by “hacking” old/earlier presets and then importing them back into a running PL6.

Backing up presets is as important as backing up the database, or more important if you are just using the database as DxPL temporary work files.

However, there is no such entry for 5 and I had trouble with “5 - No Correction” in the past but never pursued it in detail!

Hmm - thanks for the update.

1 Like

Indeed, and macOS provides the handy “Time Machine” backup feature.

1 Like

@platypus a useful facility that has no direct counterpart on Windows.

Although I did install a product (PowerQuest Drive Image) way back that captured all changes on my Father-in-Law’s machine because with his “lazy” mouse movements he moved (dragged) files inadvertently, couldn’t find them and then started again!?

Every change was captured in Zip files and I was able to “recover” what he had “lost”!

My own backup uses Beyond Compare and does not back up continually. The resulting backup is a copy rather than a history of changes so no “rolling back” to a given point in time.

Not quite that, Bryan - - I reckon it’s related to a “logic fault” (aka, a :beetle: ) in the translation from the state of “Constrain to Image” = False to the corresponding sidecar/.dop setting - which should be DistortionAnamorphosisKeepEntireImage = True … and vice versa.

@John-M I haven’t fully tested the whole story that you paint but I ran a test and was convinced that nothing was right until I discovered …

  1. Set up a new directory of 4 images, no DOPS with a ‘Preferences’ of


Which was wrong because I wanted to use ‘5 - …’ for RAW!!

  1. Set ‘Constrain to image’ to “OFF” for the first two images and left the other two alone and was convinced that DistortionAnamorphosisKeepEntireImage = False was set for all 4 images which it was


but I missed the Overrides = addition to the end of the DOP for the first two images


Now I will test with ‘5 - …’!

I think you’re over-complicating things, Bryan … Just do this.


1 Like

@John-M I made the above statement some posts ago, i.e. that I can reproduce the issue, which I just repeated with an empty database, a new folder of images, after a PL6 restart and it still gets the ‘Constrain to image’ set in spite of the fact that there is nothing in the preset that should cause that.

So no prior actions to cause values to be left behind and PL6.7.0 sets that item ON using …?

My other tests are to explore an issue that I had (or thought I had) with the “invisible” option 5 some time ago when I was using it as my default option for RAW images!

1 Like

The default for exactly that setting changed one or two times during the PL 6.x release cycle.

I think there is some state left in your preset file, or things just get messy with the changing defaults.

Anyway , recreating your partial preset should probably fix it I guess. Did you try that already ?