PL7 Nvidia GPU export not working


i’ve a Nvidia Quadro RTX 5000 in my system with the driver 537.42.

When i Choose the GPU for export the software hags as soon as it try to compute the preview with Deep Prime XD.

I’ve this Problem since i updated to PL 6.9, before everything was ok.

I’ve another system with a AMD Radeon Pro W6800 an PL does run just nice, but this system is in my Studio, so i cant access it all day.

I had already written to the support, but that was not successful.

There it is only about deinstall etc. It is a BUG.

Does anyone have an idea how I, not about dubious sites come back to version 6.8, until nvidia or DXO have fixed the crap?

I have an update.

I have fixed it myself.

By means of Topaz Photo AI, no I have not replaced PL but:

Both programs use DirectML and onnx to run the AI models.

So I got the onnxruntime.dll and the DirectML.dll from the PhotoAI folder and replaced them with those from PhotoLab, since then the software runs, or does not get stuck with Deep Prime XD enabled.

I.e. either the onnx.dll is defective or the DirectMl.dll or both.

There also seems to be a connection with drag and drop, when I paste images from capture one into PL7 to de-noise them, PL7 again blocks the export and preview with Deep Prime XD.

That’s interesting, Mr J … Just to clarify, tho - Did you mean;

  • replaced the PhotoAI versions with those from PhotoLab
  • replaced the PhotoLab versions with those from PhotoAI


oh sorry, i did take the one from PhotoAI into the folder of PhotoLab, maybe the one of PL are broken.

1 Like

Seems much more complicated than that.

Now it blocks again.

My workaround is to apply my preset to the images and export from the library so the DeepPrime preview doesn’t run.

In that case, it may simply be that your GPU is not up to the task (?) … But, curious that it was working OK with PLv6.8 - - but now, not with PLv6.9

The Quadro RTX 5000 is just fine, it worked until 6.8.

Its not working with 6.9, 6.10, 7.0.1. but all version before.


I tested PL 7 using my Win 11 laptop with Nvidia GeForce RTX 3050 and DeepPrime export didn’t complete either. I tried exporting a batch as well as a single image. and the export timed (ie 20s remaining) would count down to zero, and then just hang there. No image(s) were ever exported.

Additionally, I actually had to uninstall the program because it stopped the ‘SamsungPortableSSD’ app from working on my laptop. This app allows the SSD (Samsung T5 drive) to be encrypted, which is great for me as I carry the SSD everywhere and it has my work on it - should it be lost, then at least it is encrypted (the files are backed up when in the office btw).

Anyway, before I installed PL7 I connected the SSD and could access the files (you have use the ‘SamsungPortableSSD’ app to bypass the encryption). I disconnected the drive and around one hour I installed PL7. I then reconnected the drive to access my files so I could test PL7 with them. The Samsung app would attempt to start and then crash before I could enter my password. I could not access the drive.

The only thing that had changed was installing PL7.

I uninstalled PL7 later that day and the Samsung app worked again and I could access the SSD.

Any driver upgrade to do ?

Not really a helpful comment, but my 3070 has no problem exporting with DeepPrime XD and so. I am on Windows 11 and using DxO Photolab 7.

My laptop with an AMD 500 series GPU initially failed DeepPrimeXD with revision 6.9 & newer but worked with rev 6.8.

But I found that I can get DeepPrimeXD to pass if I disable my default integrated Intel HD GPU driver while leaving my AMD GPU enabled. I also changed my Graphics Settings from “Let Windows decide” mode (which chose the Intel GPU) to instead use AMD GPU in “High performance” mode.

I know DxO had in fact been using my AMD GPU for DeepPrimeXD successfully for many revisions of PL before the update to rev 6.9. After the update, I believe DxO changed the way it handles the GPU, and so now on my machine if that GPU isn’t used for the whole system, then DxO’s new GPU handling method stumbles over something and fails. But forcing the whole system to always use the AMD GPU solved the problem.

Unfortunately, even after rebooting a couple of times using the AMD GPU for the whole system, I have no control over my display brightness. I have to work that out now (hopefully). So, changing the system’s GPU can raise other issues with the system that you might have to iron out.

a) be sure that your chipset and graphics card (amd) drivers are up to date.

b) realize that the 500 series dates from 2017, is well past end of life, and any continued functioning with high-end software is at this point a happy accident.