PL6 stops loading all previews halfway with 'loading please wait ...'

Interesting to see your numbers Darrell.

I did a couple of tests: First, I started PL6 pointing at a directory with 1004 raw files. It loaded the thumbnails for 925 of those and then stopped. The remaining 79 fail to load and are stuck on ‘loading please wait’. I then repeated the above for a different directory with 1048 raw files. Closed and re-started PL6. Again PL6 gave up after loading 933 thumbnails. PL6 seems to hit a limit and then give up.

If I then move to another directory whilst within PL6 it refuses to load any more thumbnails from this new directory - again it seems that it has reached a limit.

I also checked with a directory with fewer than approx 900 files. I pointed PL6 at another directory with 417 raw files then closed and opened PL6 and it loaded all thumbnails.

This is all on the Windows version of PL6.

1 Like

It sounds like a memory problem. I wonder if increasing the cash size which I think is in preferences. I do not keep enough files in a directory to test myself. I’m only guessing.

That’s one of the first things I checked on my PC, my cache limit was set to 15000MB and the cache was at only 340MB. On my laptop it was a new installation, though I didn’t check it the cache was probably quite small.

You don’t have to have a lot of photos in one folder, just keep going to different folders and let all the thumbnails load until you run into a problem.

It seems to be easily repeatable so it should be no problem for the DXO team to get the problem also.

Unlikely to be a cache problem. First thing I checked too. only a fraction of cache used. And the cache parameters have not changes since PL5 and PL5 had no problem loading thumbnails for thousand plus files in a directory. It was very performant.

Agree Darrell - this PL6 problem is easily repeatable and it is also really irritating. I now rely on FastRawViewer to review files as I cannot see them all in PL6. Hopefully a fix can be found soon.

1 Like

This problem was maybee the tipping point for me to leave Photolab. Photolab has always being so stable, but not anymore :frowning: Now with version 6 it often used to freeze for me despite I have a new and fast computer.

PL feels more like Lightrom in the old days say 10 years ago.

I am sorry to here that. I am using PL6 on an older, slower computer, with an old GTX 1050ti graphics card and for me performance is excellent. I am primarily processing 21MP Nikon NEF files, so if you are using much larger raw files that would slow things down a bit. I rarely have more than 600 or 700 raw files in a folder and have never seen this problem. How many raw files are in your folders when this problem occurs?


Have you got a positive response from DXO about this? It’s getting a little frustrating have to restart the program.

1 Like

I never have that many files in one folder. Usually not more than a couple of houndreds. Still I had that problem. It also started to ask me for confirming profiles I have confirmed using many versions ago and maybe that was the cause of the problem but I don’t know.

I share Sten-Ake’s frustration. I’ve had PL2,3,4,5 with no stability issues whatsoever, so this is frustrating. I also have C1 and have started to use it more as the issues I am encountering scare me a bit:

  1. The issue in this thread … I cannot load all thumbnails
  2. Another issue - which is that PL6 on 3 occasions now have failed to load/detect all the NEF files in a directory. I get a dreaded White X in a Red Circle next to the number of images loaded. The only way around it is to move NEFs to a new directory but then I lose all my edits. Many many hours of edits. Looks like the database/catalogue gets corrupted somehow. Googling it seems a Win issue which may be known. I logged an incident ( but no feedback at all so far.

I have made no changes to my Win11 PC since upgrading from PL5. So this is PL6 related.

I use Nikon NEFs from Nikon Z9 and Z7 … so relatively big files at approx 50Mb and I have regularly several hundreds up to 3,000 in a single directory for a shoot. No issues at all with PL5 (once Z9 was supported :wink:

I have the following setup:

Win 11 Home Edition
AMD Ryzen 7 3700X 8-Core Processor 3.60 GHz
RAM 64.0 GB
NVIDIA GeForce GTX 1660

1 Like

Just an observation, but this seems to be an issue for some PL 6 users on Windows 11. I believe most of us still running Windows 10 don’t have this issue with PhotoLab 6. Even If there are some users on Windows 10 also reporting a similar issue, the cause may be some type of hardware or software conflict. Problems like this can be difficult for developers to resolve if they are not able to recreate them on their test machines. It can be especially difficult If the problem is reported by a very small percentage of users whose hardware and software environments are similar to those who are not having a problem.


Loading between 150-200 files is the norm for me on Windows 10. To the best of your knowledge have any Windows 10 users reported a similar problem? Hopefully it’s a Windows 11 only issue which would presumably help DxO isolate the problem.


I dont think its got anything to do with the number of photos in a folder, it just seem to hit a limit, whether it’s in one folder or multiple. I’m running Windows 10 and it does exactly the same thing on my Windows 10 laptop as well.

If you only have a couple of hundred photos in each folder, let the thumbnails all load from several folders till you have loaded over 1000 and see what happens.

Yes - I find the same on Win11. It can load approx 930 NEFs (mine are 50Mb but that probably has little to do with it). It seems to hit a limit (cumulative size of thumbnails? file count?) and then gives up loading more regardless of folder and number of files in each - it is a cumulative issue. Only way to see more thumbnails is to close and re-start PL6. Then it starts again from where you are and loads till approx 930 … argh!

1 Like

I’m also using Nikon but my NEF’s are only around 30MB. Maybe I should try my Olympus folders to see if the limit is the same.

I tried to recreate this problem by opening well over 1100 files in 5 folders in PL6 on Windows 10 and could not recreate it. Am I misunderstanding something?


This not a specific Windows 11 issues, issue exist in Windows 10 too and it’s not a memory problem.
I change the virtual memory (Windows Cache) to 12 GB and my ram memory is 32GB and I still got the problem.

If you want to recreate, please keep on loading images until you get ‘Loading image, please wait’,
it may be more that 1000 that you need to load. I think this depends if the previews already exist in the cache or not. If they don’t exist, issue occurs around 1000 images load. In the example I sent to DXO support, the file I load contain 1188 images.

The issue I have logged with DXO support is being reviewed by the development. I believe it’s an application issue in PL 6 as I don’t have the same issue in PL 4 on the same computer loading the same files.


DXO owns this forum but still doesn´t seem to pay all that much attention to it I´m afraid.
I don´t think they are doing their job.
A forum like, this discussing problems with their main product Photolab ought to be one of their main input sources of theirs, don´t you think? … but I don´t see their presence here. Why? You tell me.

I have said it before:

It doesn´t take thousands of images to trigger this problem. In my case just a few houndreds. There has to be other parameters too involved in this problem. I sure have some 25 000 images under a top folder in a large catalog tree but never thousands of images in one single folder. I have worked with corporate DAM-systems and are aware of “best practices” building systems like that. In fact we had an automatic configuration in our Fotoware DAM that autogenerated a new folder in every single index when a folder reached 1000 images.

I can also say that I have been to quite a few safaris in East- and Africa and in Asia over the years and I can´t remember ever coming home with more than 1000 images from any of those. I don´t pray and spray and rarely takes more than two images of a motif. It´s not necessary with modern Sony AF - unless you are a bird photographer, and I’m not.

I think Photolab has hit the same kind of limitations like Lightroom hit 10 years ago. There is a problem when you have to live with both the demands from ImageLibrary who needs small previews for speed and big previews for detail editing in the RAW-converter. In Lightroom they have solved it with compromising the quality of the previews. That´s why the application needs time whenever zooming in when editing.

Photolab now have it’s ImageLibrary and exactly the same performance problems as Lightroom had ten years ago when I left if for Capture One.