PL6 no longer processes images shot in APS-C (crop) mode

Using a Sony A7CR (aka mini A7RV). I updated my PL6 Elite yesterday and discovered that images I’d inadvertently taken in APS-C (crop) mode no longer can be processed by PL6 – it mistakenly ‘thinks’ they are mRAW/sRAW images (which they are not). The thing is, I’d already processed some of these cropped images with the previous version of PL6 without any problems … in fact, I didn’t even know they were on APS-C mode until I updated the software and it ‘choked’ on them. Anyone else experiencing this on Sony or other brands? Is there any reason why PL6 should suddenly have a problem with such files?

1 Like

Following: the same thing happened to me!

Glad I’m not the only one then! I raised a ticket with support and the person didn’t seem to understand the problem. Even asked me what camera and lenses I was using and suggested that I check the compatibility list. I pointed out that I’d already specified the camera and that the issue has nothing to do with lenses, just whether the FF camera is shooting in crop mode. I’ll update here when I learn anything new.
Are you shooting Sony too?

Yes, I am shooting Sony A1, and I can’t even access the photos that I already processed in DXO. I just responded to support with the diagnostic file, so I hope they come back with something

I got the same problem. I just updated Photolab 6 Elite and can’t open the crop images of my a1 anyomore either.

Well, we can’t be the only three. Hopefully, they will fix the bug. waiting for a response to my open support ticket

Hi, I recently updated PL7 and I now have the same issue as mentioned above.

Yes same issue with update to PL7. I no longer have access to perviously edited files. The Raw is there the .dop file is there but I cannot open either one. My good fortune is I have very few of these files because it is from early testing of the camera when I first started using it.

I have an a7RV if I am set to lRaw and switch to apsc mode the camera automatically changes to mRaw. You need to shoot Uncompressed Raw if you want to toggle between full frame and apsc mode.

Check this by toggling the camera to apsc mode and then go to the menu and try to set to lRaw. It will be greyed out. Or set to lRaw with apsc off then go to shooting mode and toggle to apsc mode and go back to the Menu and you will see that it has been switched to mRaw by the Camera.

Testing files from a a7RV in PL7.4
sRaw and mRaw: Does Not Work
lRaw: Works
lRaw in apsc: Does Not Work because camera auto switches to mRaw.
Uncompressed apsc and Uncompressed full frame: Work
Compressed Raw:Work
Compressed Raw with apsc: Does Not Work

@Daniel But I’m shooting compressed RAW (not lossless) and still have the problem. So, I don’t think it has to do with RAW format. And as we’ve experienced, PL6/7 was working fine with cropped files until last week … it’s not supposed to work at all with mRAW/sRAW files because they’ve been demosaiced already (I believe).

Yeah, Understand. see my list only Uncompressed apsc works. I think Compressed apsc gets reset to mRaw also. So weird that it was working, my edits of those file looked fine and now they will not open. The Uncompressed is 130 MB and the Uncompressed apsc is 61 MB. So you get the extra reach with a small file, but if you switch out of apsc you have to deal with the larger files.

@Daniel Well, there’s certainly something strange going on. What we have is the following:

  1. DxO says that PL cannot process mRAW/sRAW files because they are not ‘real’ RAWs as they’ve already been demosaiced. But PL could process the APS-C format RAWs before the update, which suggests they are not mRAW/sRAWs coming out of the camera files and being are being mis-identified as such by PL.
  2. Windows Explorer gives jpeg information (and shows icons for) Compressed RAW in normal and APS-C mode, but not for mRAW/sRAW files, so it ‘knows’ there’s something different about those latter files.
    BUT
  3. This is the image information that PL gives (slightly different compositions so MBs are not reliable):
    Compressed RAW: 9504x6336 63.3MB
    Compressed RAW APS-C: 6240x4160 27.9MB
    Compressed mRAW: 6240x4160 41.7MB
    Compressed mRAW APS-C: 6240x4160 32.2MB
    Compressed sRAW: 4752x3168 33.8MB
    Compressed sRAW APS-C: 6240x4160 32.5MB
    (Interesting that once you are in APS-C mode, shooting mRAW/sRAW doesn’t provide a file size advantage … which may be consistent with what you’re suggesting. But then see #1 and 2 above).

Very confusing.

OK, I heard back from support with a much less satisfying answer than I’m used to from DxO. I previously had to highlight/repeat to the support person that I’d already mentioned my camera body in my original report and that compatibility was not the problem (the person is not reading my emails closely). I also had to repeat that everything was fine before the last update and that files I’d already processed were no longer readable by PL6 (along with a screen shot showing this along the error message as well as a sample RAW).
The response this time? “Please be advised that the image you sent is in either mRAW or sRAW format, which PhotoLab doesn’t support those formats.” That’s it. SIGH. So I’ve replied with an explanation of the differences among the formats, along with files demonstrating that (i.e., that mRAW alters the apparent resolution of the full sensor image while APS-C alters the framing, using only the middle area of the sensor). I’ve also repeated (third time) in bold that it was all working well before the last update. Let’s see what happens next.
Anyone else here having more luck with support?

Thank for the hard work, I hope someone there understands the problem. I have Raw files and .dop to match that show clearly it was working before my update. I am sure you have same examples. I wonder if the .dop carries the version that was used to create it?

Sidecar = {
Date = “2023-12-22T01:30:58.7570000Z”,
Software = “DxO PhotoLab 7.2.0.42”,
Source = {
CafID = “C94319b”,
Items = {
{
Albums = “”,
CreationDate = “2023-03-26T14:15:36.2150000Z”,
IPTC = {
contentDescription = " ",
},
Keywords = {
},
ModificationDate = “2023-12-22T01:30:58.7570000Z”,
Name = “_DSC0591.ARW”,
Orientation = 1,
OutputItems = {

Yes it does, see 7.2 created this .dop that now will not open in 7.4

On a Mac I opened with the text editor. Take a look at yours.

We’re thinking the same way. Yesterday I sent a follow-up message with a previously-processed crop-mode file, the resultant jpeg, and the .dop file - all to prove that their software used to work fine with such files. The very fact that there is a .dop file at all makes the point (if a file can’t be processed, a dop won’t be created). I hope the support person will now better understand what’s going on.
p.s. your dop shows ‘DxO PhotoLab 7.2.0.42’ … that’s probably the sort of thing they need to see

1 Like

Tomorrow I will contact support and lead with the sample files. I will keep it simple it worked in 7.2 and now it does not in 7.4 please tell me why. I will not get into Raw types or apsc mode. Just it worked now it does not.

OK, the support person just asked me to set up a log file, try to open a problem image, and send them the log file. Done. Let’s see what comes next.

Update: She seems to finally accept that it’s a problem that only arose with the last software update a couple of weeks back and has sent the issue on the to development team.

3 Likes

I will admit that I reloaded the previous build from my backup instead of going in circles with support. Thanks for your work on this; you definitely have more patience than I had with them.

I got the old installer from support for a temporary workaround. If anyone does not have the old installer, it seems good to contact support with the URL of this forum.

Going back a version is a Catch 22 for me. I previously had a problem with PL not sufficiently correcting barrel distortion for a 24mm lens on my ‘new’ body (A7CR). The latest update seemed to fix that (I had worked with support on that issue too), but then broke on the APS-C size RAW files. Seems like I can’t win :grinning: I’ll just have to be patient and hope that a fix comes through soon.