PL6 - Lens model not detected correctly anymore

Hi everyone.

Might be a bug in the lens module recognication in PL6:
With PL5.5 Build 4770 the lens is detected correctly as Zeiss Makro-Planar T* 50mm F2.0 attached to a Canon 5D MkIV

PL6 Build 3 insists, that the same image was taken with a Zeiss Planar T* 50 mm F1.4 ZE

Ideas on how to fix this?
(my other lenses are detected fine btw.)

Sample file is attached.
IMG_1189.CR2 (34,6 MB)

No idea. Had the same with a Sigma 35/2 which PL insisted to be an APO-Summicron 35/2. But they say “vermutlich”, so they also admit some insecurities there… :grin:

My workaround was “deactivating the wrong profile and give it a manual correction”, but it adds unnecessary steps to my editing workflow. Maybe @Marie can help you out what to do?

have you tried uninstalling the module?

Hi Sigi.
Thanks for the suggestion. Tried it first with PL5.5. That leads to PL5.5 to now also think that all the other images taken with the Makro-Planar 50/2 were taken with a Planar 50/1.4 and that i should install that module… So that kind of looks like the issue does not come from the new PL6 itself and more some kind of optics module database change?

Thanks Joachim.
Jep the manual steps are excactly what i wanted to avoid. Especially since it used to work fine out of the box for me the past years.

I hope DxO will fix it with the next update.

Does DPL propose to you several lenses to choose from when it encounters these files or does it only propose the wrong module? If if proposes several lenses, the moment you pick the correct one, it should be applied to ALL the files automatically which were taken with that lens.


Hi Sigi.
DPL only proposes one: the wrong one (50/1.4).

I guess then only @Marie can help you.

Hello everybody,
this issue will be fixed with the next modules release, probably in December. It will update the CAFList.db file.
We have improved matching between images from Canon cameras and DxO Optic modules but here it appears that Exif information in the image are wrong, LensInfo tag has 50mm F1.4 instead of 50mm F2.0, that caused the issue.

1 Like

Perfect. Thank you for the reply Barbara!

Have the same problem with my Viltrox 23mm F1,4 for Fuji X-T(4) IS RECOGNIZED AS A FUJINON XF 23MM 1.4R (RAW), on both version 5 & 6 elite.

It’s interesting that a company relies very much on individual DOP files is at the same time relying very much on a not very frequently updated database for their lens profiles. In the meantime we need to use none or wrong profiles, right? I think I save the time to check if the Sigma 35/2 ist still confused with the Leica APO-Summicron as it has been for half a year or so.

It should be easy to exchange that module database file from a backup. That could help, unless DPL regularly overwrites the file.

Hello @ Ruediger_vS
this issue was fixed with this weeks release

Hello @Barbara-S
Thank you for the heads up and fixing it. Just checked and i can confirm: it works :+1: