PL6 crashes every time after startup

This behavior in PL6 first appeared after trying to use my PNG-based presets in instant watermarking.
These presets where build and used in PL5 and still working fine there.

Even a reinstallation of PL6 does not change crashing PL6 after every try to launch the app.

The machine PL6 is installed on is Windos 10 21H2 (19044.2130)

Meanwhile i had to switch back to PL5 on the same machine.

Please open a support ticket at support will take a look at it.

1 Like

Here are some additions from my recent tests i made to bring PL6 back to life and hopefully encircleing the root cause…

At first - i moved the critical pic-folder including nikon-raw- and .dop-sidecar-files to another place, PL6 did not touch so far. After that step i could launch PL6 successfully again.
Secondly - i moved the isolated folder back to its previous place but this time without .dop-files and PL6 crashed again after every try to launch the app.
Tirdly - i deleted the .dop-files and the PL6-database (PhotoLab.db) in its win-10 known folder.
At this time and relaunching PL6 with a maiden database i finally was able to edit my raws in the critical folder.

Anyway, at this point of testing, while working on another rawfile in PL6 after trying to place a picture-based (small jpg or png) watermark the problem came back immediatly. Trying to make an jpg-export from this ends up with an Error-Message (!) and subsequently PL6 starts crashing every time trying to launch it.

For me it looks like something is currupting the database and/or the .dop sidecar-file with using picture-based “instant watermarking”

Someone else with similar experience?

I hope DxO will take a look on that!

regards Peter

@supernaut , have you tried to rebuild your watermark in DPL6?

Hi platypus, yes i tried to rebuild a new one but without fixing it. I tried different things. I tried it to with small png and jpg files who work fine in PL5.

I just opened up a support-ticket as Mark from Dxo recommended.

Hope DxO will have an eye pealed on that

Okay… I tested it on Mac, but found no issue. Tried it with a png with and without alpha channel, but it made no difference. Watermark .preset files of DPL 5 and DPL6 are identical, except for their version numbers (17.0 in stead of 16.2 and 16.0 respectively).

Thanks for checking that! My assumption is that it is not the presets itself and their migration from PL5 to PL6 but instead the usage of instant watermarking within the brand new PL6.
Using instant watermarking only with pics without any existing PL5-presets are producing that problem.
On my win10 machine trying to insert a small jpg or png as a watermark is leading into that trouble and in a way is currupting the db or .dop-file and making it crashing the app at startup.

Prolems described here are fixed in PL6.0.1 Build 33