PL6 can't export result

I downloaded the trial version of PL6 (Windows 10) and reworked some images to investigate the benefits of Deep Prime XD.
Usually, I export as .dng, to further process the result in another application. In many cases I’m confronted with an internal error; the image is processed, but the result can’t be saved. There is no problem if I copy the file to another location, e.g. a Temp folder. But if the RAW file is in the original location and I want to save the result to the same folder, the error occurs.
Anyone with the same experience and a possible solution (other than copying the to be processed RAW file to a different destination first)?

For what it’s worth, I’m also on Windows10 and have never had that problem.


Issue with access rights? Looks like PhotoLab can read from the original folder, but not write to it…

Any naming collision problem?
Any permissions problem on local vs external or network storage?

It does sound like a “permissions” issue - as others have suggested.

Here’s a workaround that should help;

  • In the Export to Disk dialogue, provide a pathway to a Custom Folder …
    image … to, say, your Temp folder.

John M

Thanks @mwsilvers , @John-M , @Required and @platypus for your suggestions.
Yes, it sounds like a permission problem. The annoying thing is, that it happens after the (slow) processing with DP-XD. I never experienced it with PL4 or PL5, that’s why I’m so suprised and therefore I don’t think it is a Windows permission problem… It can easily be circumvented of course, but there must be some cause.
Maybe the problem is in the already existing .dop file, that will be different between PL5 and 6. I’ll try what happens if I copy the raw file with and without the dop to another folder, or if I delete the dop in the original folder.

I’m not sure about Windows permissions but macOS permissions can be different fro each version of an app. Just because permissions are set for PL4 and PL5 doesn’t mean they are set for PL6.

Thanks @Joanna for your time and comment. Much appreciated.
In the meantime I found out, that it is not related to the presence of a dop file, and that the problem is restricted to the original location and subfolders of the original location.
But: the first time I opened PL6 today, I tried to save a processed file after denoising with HQ, Prime, DP and DP-XD and all 4 results were saved to the original location! I closed PL6, tried again and the internal error occurred: result not saved. More and more I get the impression that it is a Windows issue, but it will be hard to find out what it is and how to solve it. It reminds me to a somewhat similar problem I have with ExifGUI: sometimes, after changing Exif data, ExifGUI can’t save the result. This is definitely a Windows issue, but also hard to solve. Sometimes the solution is in removing the embedded JPG from the RAW file, sometimes that doesn’t work. The internet is full of questions about this type of saving errors, but there are no solutions that always work.
Most annoying.

The XD is a more complex process and do take longer time to complete from initial file creation to full write out of the file.

I’m guessing some here :slight_smile:
Might it be that you are storing the raw files on volume or in a folder which have a synchronisation process for it? Perhaps in a folder with OneDrive or GoogleDrive et al?
Some sync services are notorious for locking and write protecting the file during syncing.

Running a less time consuming denoising would allow PL to write the complete file before the sync and file lock kicks in.


Well, storing is only local. I don’t use any storage in the cloud, no OneDrive, Dropbox, GoogleDrive or the like. My backups are local, on usb disks or even DVD (very oldfashioned, but on the very reliable Kodak Gold DVD’s at least).
But I’ll keep searching…