PL5 won't launch since installing PL6 trial

PL5 hangs at the startup screen, “Loading main window…”
Wassup wit dat?

Check that PLv5 & PLv6 are NOT both sharing the same database - as PLv5 won’t like that at all !

See Preferences: On Win-PL it looks like this; image

John M

In my standard installation of pl6 it was referring to the database of pl5. That seems to be a bug.


Thanks, but you’re talking Windows-speak in the DxO PhotoLab Mac forum. On the Mac version, there is no preference setting that addresses this.

How do you know, and how does one fix this? I see nothing relevant in PL6 preferences.

See the post of @John-M .
Edit->Preferences->General. At the bottom.
Reading your original post, this is another issue.

You, too, seem to be referring to the Windows version. On the Mac version, Preferences are under the DXO Photolab 6 menu, not the Edit menu. And, there is no item under General, or anywhere else, pertaining to a “DXO Photolab database”.

I don’t pay always attention the the categorie. I’m sure I’m not the only one.
It’s not that busy on the Mac side :face_with_hand_over_mouth:


Regardless, Jacques - that’s still a likely explanation for your experience.

Can any Mac users out there advise where Mac-PL stores its database ??

John M

On Mac, the DPL databases are in Library/Users/Username/Library/DxO PhotoLab v5
To see it you have to clic on Alt+Go in the Finder menu.
And of course v6 pour the new one.

Thanks. I see separate folders there for PL4, PL5 and PL6. So I guess that’s not the issue. PL4 and PL6 launch just fine, but PL5 still hangs on launch.

FWIW, there is no Alt key on Macs. On a Mac, the user’s Library folder is accessed by holding the Option key and then clicking “Library” in the Go menu.

This is my Apple French keyboard:

There should be other keyboards mapping, but on mine I have the Alt key.

Option and Alt are two names for the same key. Historically it used to be known as the Option key but is nowadays known as the Alt key.

It seems nobody here actually has a solution or an action I can take. PL5 still isn’t launching. And my PL6 trial is about to expire. Thanks, DxO, for putting a gun to my head. I was going to upgrade anyway, but I really don’t appreciate having the trial disable my paid version, leaving me no alternative but to fork over $99 right away.

Have you tried to edit images in PL6 that are in the folder that PL5 is trying to open?

There is no reason why installing PL6 trial should stop PL5 from working, unless you have used PL6 trial to edit images in the folder that PL5 is trying to open - in which case, some of the DOP files might have been changed.

Do you know which folder you last used in PL5 and whether or not you have edited images from that folder with PL6?

Hello there.

Have you contacted DxO support?

Try to rename the PL v5 folder and launch PL5 again.
/Users/username/Library/DxO PhotoLab v5

Same with Application Support folder:
/Users/username/Library/Application\ Support/DxO\ PhotoLab\ v5

You can do the same with the plist-file.

Supposing you have a backup that dates from before the issue appeared…

  • Restore the DPL5 app from a backup that predates your DPL6 trial installation
  • Rename the /Users/JACQUES/Library/Application Support/DxO PhotoLab 5 folder
  • Rename the /Users/JACQUES/Library/DxO PhotoLab 5 folder
  • Delete the /Users/JACQUES/Library/Caches/com.dxo.PhotoLab5 folder

Take one step at a time and see if it fixes the issue. If it doesn’t, take the next step.

Hint: replace JACQUES with your actual user account name :wink:

Before you try @platypus’s suggestion, you might try something easier-to-do …

@Joanna’s suggestion/suspicion is a probable one … You can test it out as follows;

  • Create a temporary test folder
  • Move to it just one of the images (without its associated sidecar/.dop file) from the folder that PLv5 is opening by default
  • Temporarily, rename the folder that PLv5 is opening by default - so that PLv5 won’t crash again when it encounters that folder (with, possibly, sidecar files in PLv6 format)
  • Try running PLv5 again … If that works OK, point it at your temp/test folder
  • If PLv5 can successfully open the temp/test image - then Joanna’s proposition is correct … and you will need to either; i) Delete all the sidecar/.dop files that have been updated to PLV6 format, or; ii) Move to PLv6

HTH - John M

Thanks to all who’ve helped. I first uninstalled PL6 and all associated files, to no avail. Then, I dropped a virgin folder on PL5 in the Dock, and voilà, PL5 launched and opened it right up.

Just in time, too, as I’ve got a job to process tomorrow, and my PL6 trial has expired. I’ll pay for the upgrade when the Black Friday sale rolls around. I don’t really need PL6, as DeepPRIME does a perfectly good job on my ISO 25,600 event images that go straight to social media. I’d like to have DP XD, though, for the occasional large scenic print, and there’s probably some other good stuff that I haven’t discovered yet.

P.S.: Now that I’ve got PL5 open, I am able to view images that were processed with PL6 in folders containing the resulting .dop files. Go figure.

This is a waste of time as each version installed on macOS is an independent bundle, with no reference to any other.

This is more than likely because you had worked on PL5 files with PL6 and then gone back to the same folder in PL5, where it promptly barfed when trying to load the PL6 DOP files, which are not compatible with PL5.

Yes, but it will not necessarily read all the edits you made to those images with PL6

1 Like