PL5 very long startup time

Ever since the upgrade to PL5 the startup time for PL5 on Windows has been extremely long (just measured three minutes). I originally updated to PL5 on a Windows 10 machine, which has been upgraded to a Windows 11 machine, but the long startup time was there for both versions of Windows.

I have a log file that I can submit, if that helps. About half of that time is spent on approximately 100 iterations of the following task (per the log):

2021-12-03 17:27:48.984 | DxO.PhotoLab - 10944 - 1 | ServiceLocator - Info | Profiling DxONET.Extensibility.ServiceLocatorInitializerRegistry.RegisterFolder :   48 694 ms

The entry above is the worst case, some are only fractions of a second, some are multiple seconds. Overall those actions add up to about 1.5 minutes of the total start time – but the total start time is about three minutes.

Using this identical machine, with older versions of PL, the start delay was not nearly this long, especially the time to get to the “starting banner.” Sometimes I think PL5 did not start because it takes so long to see the startup banner.

1 Like

This may be specific to your machine. No one else has mentioned this issue as far as I know. On my aging mid level Windows 10 machine PhotoLab 5 is fully loaded in 15-18 seconds after I click on the icon, similar to PL4…


Never had this problem – but noticed, that PL5 loaded a folder with a couple of ‘complicated edits’ (from PL4) much quicker than before.

I’ve always had this problem with Photo Lab 2,3,4,and 5. It can take 3 minutes to open… My standard fix is to delete the database file, and it starts much faster… Delete or rename this file…

%Appdata%\Roaming\DxO\DxO Photolab 5\Database\PhotoLab.db

My Win 10 PC is a lowly 3rd generation i5 CPU with 8GB RAM. PL5 takes about 30-40 seconds to open.

My Win 10 PC is a Ryzen 9 5900X CPU with 64GB RAM. PL5 takes about 20 seconds to open

Thanks to all for the quick feedback and suggestions. I tried @rlebleu’s suggestion (I renamed the PhotoLab.db file):

…My standard fix is to delete the database file, and it starts much faster… Delete or rename this file…

%Appdata%\DxO\DxO Photolab 5\Database\PhotoLab.db

but that had no impact.

So I enabled the “Edit > Preferences… > General (tab) > Metadata synchronization” option and copied back my old PhotoLab.db file. Now PL5 is loading very fast!

1 Like

And it’s back… the long delay to opening splash screen. :frowning: So above did not help.

Have you tried reinstalling it? When you reinstall over an existing copy it gives you a repair option. It may not fix your problem but it’s worth trying. My guess is something else is affecting PhotoLabs very atypical startup performance on your computer.


Hello @xmnboy ,

Your problem seems rather individual, so let me recommend you to create a support ticket via because additional info like collecting memory dump and other will be requested.

Svetlana G.

1 Like

Same problem here so it is not individually related. PL5 takes about 2 minutes to load and start in Windows 10 where others start in less than 10 seconds. The blue loading bar hesitates around 2/3 mark and sits there until it’s ready to open at about two minute mark.

The DxO PhotoLab 5 folders in the my Documents did not load either on installation. Windows blocked them until I did it by allowing it in the Ransomware section under “Allow an app through Controlled folder access.” You may ind some DxO apps/exe by clicking the “+Add an allowed app” and the “Allow a recently blocked app” and seeing if something by DxO is missing.there. You may find a lot of older DxO versions in there too as their installer doesn’t seem to fully clean older files. I had old Dxo Optics and version 4 still residing in there.

Lots of PL5 bugs seem to be related to Windows 10 ongoing Security fixes. However, it is still very slow to open here with all current Windows 10 updates and video drivers installed.

Support ticket has been sent, but so far no success with any responses.

I have the same issue, it takes at least 2 minutes to load PL5. I’m using a Lenovo Legion gaming laptop (Windows 10) with an Intel I-7 2.6ghz core and an Nvidia GeForce RTX 2060 graphics card. I run it overclocked to process raw files. The program is loaded on a 1Tb ssd. It should not take so long to open.

Installed 5.1 in Windows 10 Version 21H2 Build 19044 .1387.

Still two minutes to load and launch.

My startup problem appears to be resolved, although, I’m not 100% sure of the solution.

Support told me the following:

In the past, when customers have reported a similar issue when using DxO PhotoLab, the problem was traced to either another program or process that was running in the background that was causing the poor performance in PhotoLab. PhotoLab had to wait for the resources it needed to be released by the other program. This is why when you first start the program it takes so long to start and then subsequent starts work better.

Another possible cause is the number and size of photo files in the startup file folder you have chosen. If you have a very large number of files in the folder, and they are, on average, large files, such as camera RAW files, this can cause delays.

It appears that uninstalling PhotoLab 4 resolved the issue (not sure why this would make a difference, as I was not running PL4).

The other thing I did was shutdown a background application called PHOTOfunSTUDIO which is an application that transfers videos off of a Panasonic Lumix camera. After doing that my startup time for PL5 was normal. However, after a reboot, PHOTOfunSTUDIO is once again running its background service but is not interfering with my startup time.

I may never know what the precise source of the issue was, but I do believe it was due to multiple processes competing for resources (the first solution they provided).

Hope this helps others having the same issue.

1 Like

Thanks for the uodate.

I’ve used DxO for years now. Not only was Photolab 4 still there, but I I still had Photolab 3 there too… Deleted both, and did a Photolab crawl looking for ancient segments of the deleted versions. Found Photolab* files in Appdata Local and Roaming and logs files in Documents - Deleted them all…

Rebooted (in case) and started Photolab5. Took 59 seconds to open. Deleted the Database and Photolab 5 was ready to go in 15 seconds. I’ve been doing this for years now. I even tried to write protect Photolab.db but that did not get past the startup…

Gonna try searching for Photolab.db in case there is another copy somewhere…


Thanks for sharing your search for the old databases, @rlebleu. I took a look on my system and freed up ~10GB of space being consumed by PhotoLab versions 2, 3 and 4!

The uninstall for pl is very poor and it’s been raised many times. There should be an option to keep the old data for anyone that wants to do so, but s default of clear it all out

A possible fix… Not sure if this was the issue. I use a security feature called Controlled Feature Access which prevents new apps from accessing AppData without my express approval. Turned it off, and PL5 loaded real quick.

Had a look at the Apps that I gave permission to store files. I found a number of unused apps… Photolab 3, Photolab4 etc… Removed them, and Photolab 5 starts much faster…