PL5 version 5.3.0 and 5.3.1 issue


When I select a folder of new files it does not find all the files in the folder, approx the first 100 are missing.

They are visible with the PL icon in W10 explorer and also FastRawViewer ‘sees’ OK but PL5 of either version stubbornly refuses to show the files in the thumbnail view.

Plus, from FastRawViewer or right click picking one of the unseen by PL5 files and sending the file to PL5, when it launches it says “no file selected”.

I do hope that there is a readily obvious solution so that I can get on with editing my OM-1 .orf files :slight_smile:

I know you’ve probably already thought of this but since you didn’t mention it in OP, I’ll ask. Do you have one of selection filters activated, perhaps by accident?

1 Like

If a file shows the PL icon, that usually means it is a DOP (sidecar) file, not an image file.

@Joanna, if PhotoLab is selected for the default application for my raw and jpeg files, than the PL icon is shown for each of them in the List or Detail view in Windows Explorer. The .dop files do not show the PL icon.


Until he confirms that is not the case, it seems like the most likely scenario.


1 Like

OK. That is different on Mac. I get a “preview” icon on image file types whose default application is PL, or any other come to that, and the PL icon only on any DOP files.

Thanks all for replying.

I had not actively set any filters, I just open PL and find the folder I wish to work.

As mentioned, FastRawViewer shows me all the files and indeed I use FRV as my first culling step before any PP work and done it this way for a while now.

The OM-1 is a new body and not many programs can ‘see’ the raw .orf files so as a comparative tests I need to trial another program to compare and see if DxO PL is the outlier in this odd behaviour?

I’m not sure what your problem is on Windows but, on Mac, here’s a screenshot of a small ORF file downloaded from Photography Blog - in the Library view…

… and in the editing view after editing…

I don’t normally use Windows Explorer. I use something called Directory Opus instead. However here is an image folder displayed in Windows Explorer’s Detail viewing mode.

Here is another of the same folder displayed in Windows Explorer’s Extra Large Icon viewing mode. It starts off displaying very large PL icons which quickly change to the actual image. I have the resizable Preview pane turned on for both images.


Hi Joanna

I am sorry if I was not fully explaining what I see or not as the case may be:-

In Win10 explorer I can all files present (not image thumbs as my version of the OS does not support .orf files…but by files number all are there.

I can see everyone in FRV and that is my culling step i.e. I can see the images.

However, in PL5 in the filmstrip I realised there are a large number (lower number files of the folder set are just not there to be selected and worked upon.

It is just very odd, typically I might select an individual file in FRV and send it to be opened in my exterrnal editor of choice i.e.PL5 but when PL5 opens it says ‘no image selected’.

I hope that makes more sense and covers the situation more fully :slight_smile:

Although I don’t have that camera I downloaded a number of ORF files during testing and didn’t see any issues. Can you upload a few of the missing ones so we can try to recreate the issue? Can you describe in more detail what you are seeing, or not seeing? What is the order of the images? Are the missing images together in a group or are they scattered throughout the folder? If in a group should they have been visible at the top of the folder, the bottom of the folder, or somewhere in the middle?



Right, by way of an update and extra info…

I have installed a trial of On1 2022.5 and in readiness to see what this program ‘sees’ in the folder I have created a new folder and copied all the 582 files to it.

On1 shows all 582 (the start number is file 2039 to 2971 ~ note I did say I had culled already to there are various gaps in the sequential numbering!

I then opened PL5 again and the filmstrip of the original folder shows 356 image files (not the 582 actually present)

I then in PL5 opened the copied folder and it then correctly showed the count as 582.

So, going back to the original folder and thinking the correct step was to “refresh” it caused PL5 to crash…

Just what is happening based on that information???

TIA :slight_smile:

…difficult to say… Have you tried the following (I do this occasionally on a Mac, if and how it works on Win needs to be tested by you before going all in)

  • empty the trash
  • in DPL, select all images of the folder that DPL is not seeing all images in - and send all images to the trash. DO NOT EMPTY THE TRASH NOW
  • quit out of DPL
  • move the trashed images back to their original folder
  • open DPL. and see if all images are now seen.

Moving images to the trash in DPL removes the respective items from DPL’s database. DPL should the rediscover the folder’s content - hopefully all of it. Make sure to check filter settings again too.


I have done exactly as you suggested and it rediscovers the exact same 356 images not the 582 present in the folder.

I surmise there is a reason for the behaviour but until there is a solution I feel that PL5 is for me not fully usable. Yes, it properly discovered the copied folder but without knowing & solving the issue I feel I could not trust PL5 to properly behave itself :frowning:

Sorry if this has been suggested already: what happens if you simply rename the folder that contains these images? (Or copy that folder and access the copy?) Does PL pick all of them up?

Filter settings carry across sessions. You are probably filtering on something stored in the dop files (or database) like star rating, tag, or processing options or status.

Crashing on refresh doesn’t sound great especially if repeatable - might indicate a dop file or database corruption issue.


I have just tried, as you suggested, plus an extra step or two.

Firstly, I made copy of the folder (this folder was designated by Win10 as ‘copy’ and the discovery by PL5 found all files OK

Then I tried as you suggested the renaming of the original folder and the discovery of that worked fine.

I then renamed that folder back to its original name and that resulted in the original problem i.e. missing files!

Obviously, the renaming worked as did copying the file to the same root as that altered the name to -copy.

Finally I copied the original (named) folder to a new location and it was discovered properly.

Something odd and inexplicable corruption happening??? Note ~ I just realised that next to the image count in the filmstrip of the missing files folder there is a tiny red X next to the count of 356 thus indicating a problem but ‘what is the problem’?

This was a fresh folder of files and I do not set filters.

But yes clearly something odd going on…please see my reply to @Egregius

if re-indexing the compromised folder does not help, your issue with the folder looks like an inconsistency in DPL’s database. The only way that I know of to “fix” this, is to delete the database, which will lead to the loss of all metadata and image customizings that have not been saved.

If you’re not ready to go that way yet, you can copy or rename the folder and simply ignore the inconsistency until you have opened all your folders in DPL and saved the settings and metadata sidecars.

Please note that your tests with renaming and copying have added things to the database, might have added further discrepancies between your folders and what DPL remembers as your folders.


As your copied folder & full content is recognized by PL … did you copy outside of PL (PL not running) or within PL?

Doing so within PL, the database should have registered the new folder properly.

  • To test it, close PL and restart! Now, does this new folder contain all your images including development, star rating and such? Invoke a virtual copy, star rating and such to write to the database as well as to the dop-file and check again (close & restart).

  • IF everything is fine in the new folder, I would just delete*) the content of the ‘faulty’ folder within PL. → You can’t delete the folder within PL, but the content, which should trigger rewriting your database. Close PL, restart and check again.

  • Rename the ‘faulty’ folder within PL, copy all those files to it, close & restart and check the renamed folder. …

  • If that all doesn’t work – delete the database.
    Otherwise, you should be able to recreate a new ‘original’ folder within PL …

*) As a precaution you can backup the folder in question and the database before manipulating !

1 Like