PL5 broken - Corrupt database? On Mac OS 11.6.3 PL 5.1.2 build 53

A long story I’m afraid… I first noticed a problem editing some older images. I would go to Photolab 5 from Photo Mechanic Plus. Everything would hang and eventually I’d get a message saying I’d run out of memory. I gave up on this particular file thinking perhaps it was corrupt. PL continued working fine on my other more recent stuff.

I decided to revisit the image, problems again except this time there was no mention of running out of memory. I looked at other similar .CR2 files and either they wouldn’t appear at all, or else the film strip comes up with previews on and there is nothing in the central panel in the Customise tab.

Now I cannot edit any files at all, even my recent ones will not appear in the customise tab. I can view the Photo library, but cannot edit anything. If I try to quit PL5 it stops responding and I have to Force Quit out of it each time. It would appear broken.

When I look at the database files, there seem to be some duplicates. Is this what is causing my problems?

If I were to delete the database files, what exactly do I lose? Will it rebuild my edits from the .dop files?

Screenshot of database files attached.

Any pointers greatly appreciated.
Thank you.

Screenshot 2022-03-16 at 16.08.15

If you have always used DOP files and you don’t rely on the database for either projects or history, then you should be fine deleting everything with “dopdata” in the extension (all 5).

But, for the sake of your sanity, please do a complete backup before doing this.

Only when you are happy that everything is “back to normal”, should you delete your backup DB files.

Do you allow Photo Mechanic to write metadata directly to RAW files? This should normally be perfectly fine but there is the rarest chance of corruption, so you might like to consider that as a possible, although unlikely, cause of problems - either that or corrupted XMP files if you don’t write to RAW files.

I have been writing metadata directly to RAW files fo many years and have never had a single file corrupt.

1 Like

Many thanks Joanna. I have never used Projects at all, and history I assume is editing history?

I will do a back up and could probably reinstate one from a while ago too. My other idea was just to rename them temporarily or move them elsewhere and see if that fixes it. Does it look odd to you that there are these duplicates?

I usually do my keywording and rating in Photo Mechanic. I am not sure if it is writing it to the raw files or xmp files - I will have to check.

The first problematic file was a tiff file which would have originally been edited in PL4, but the issue is now all files.

All of these files (even the tiff) will open in Affinity Photo, so hopefully the image itself is okay.

Thanks for your help. I’ll report on my progress.

That’s easy. If you’ve got XMP files next to your RAW files, that’ what PM is working with.

1 Like

Thank you.

When I look, my recent files have .XMP files next to them and when I look at the older ones (which originally would have been from when I used Lightroom), they have .xmp extension. I wonder if the case is problematic? I’ve checked Photomechanic and that will embed in jpegs and tiffs, but raws have .XMP files added.

I’m currently backing up.

I backed up. Then I moved all of the database files into a new folder. New db files were generated when I opened PL5 - screenshot attached.

When I open Photolab 5, it is still the same - not showing anything in the customise window - see screenshot.

I then tried going through Photo Mechanic (which is my normal workflow), and it is the same.

It is strange as it was all working yesterday. The problem file was first a problem a week or two ago, other than that it was working fine. I can’t think what has changed.

Edit: Just to add, it is not showing the image in the Photo library either, although it does show the thumbnails.
Also, I have to force quit to close the application.

Screenshot 2022-03-16 at 18.26.17

Photolab is completely unusable for me. It won’t do anything, even browse images, so I am at a bit of a loss.

Any ideas are very welcome. I wonder should I uninstall and try and reinstall?

In the meantime I’m going to have to get back in to using other software :pensive:

You could create a new user account and check if DPL runs from the new user. If it doesn’t, re-install DPL, if it does, report back… (I’ve had a broken user account a few years ago. Messed up permissions etc.)

I’d replace DPL by a new copy from a fresh download. You can use a trial download or log into your user account and download from there.

This sounds like the same problem being reported in other threads. The solution in the other threads is to disable your wifi then start PL5. It should run properly. You can then reenable your wifi.


No, this one seems different, but we may need to investigate further.

@Bebop: could you contact us through support, so we can dig further? Please refer this post in your request so we can they are linked.

Thank you. I did raise a support ticket last night. I will now go and update it with this thread link.

My OS is now 11.6.5 by the way for anyone reading now. The update didn’t make a difference, but I suspect it is something to do with this one tiff file that has upset things.

I will try the other suggestions in the thread, apart from uninstalling and reinstalling - yet. Thank you.

Just an update. I have done some more testing this morning -

  • turned off wifi - I think this made no difference.
  • logged in to a test user - was able to use PL5 - I did some testing, and was then able to go back to my main user and do more…

I had thought that the issue is with this one particular drive and what’s more, it seems to be with the particular folder. Once I have been in to this folder and had to force quit out, as long as this drive is attached, PL5 is unusable. However if I close PL5 (force quit) detach this drive, attach another one and open PL5, all is fine.

Also, if I re-attach the problem drive, it will be fine until I access that folder again, after which it will not work.

But… I have just attached my backup, that wouldn’t let me edit a .CR2 file, and I ended up force quitting again (this was not having entered the errant folder)… tried my external latest hard drive - all fine. Went back to my backup drive - and all fine again and it let me edit the same .cr2 file that it had objected to previously… so still a bit of a mystery.

One of the important things is, PL5 is now working for my current images - phew!

I will update all of this in the email ticket.

You need to be careful with this. I’ve found that PL5 will write image ratings to both the sidecars and the database, but it will not read ratings back from the sidecars (at least not the .dop files).

You will run into a problem if and when you rename enclosing folders, or if you move images from one folder to another outside of PL, which keeps track of folder locations. When PL5 sees an image file in a new location, it will import the correction data from the sidecar, but it won’t read the rating, not even if you specifically import sidecars. That may not be a big deal to most people, but for at least me, the ratings have become a handy way of tagging files.

Thank you. As I have Photo Mechanic Plus, I am trying to stick to using that for my ratings, keywords and organisation.

I have learned that my issues are related to one folder only, and once this folder is accessed I have to eject the drives and start the program again for it to be okay. The photos within the folder were all processed before I had Photolab, using Lightroom and also either Topaz or Photoshop and I think somewhere along the way, something is not playing nicely together. I am not worried now - as long as I avoid this folder it is not an issue.

Apparently it is not recommended to access Photolab via Photo Mechanic, which is what I have been doing, although I have not had any issues for the last year or so when doing this.