PL5.1: disappearing palettes

On my laptop I have my workspace configured to use two floating palette groups in order to make best use of screen space.

In 5.1 (perhaps earlier, too, I’m not sure), when I choose ‘dock to left’ or ‘dock to right’ from the drop-down (arrow) menu at the top-right of either floating palette group, the floating palette group disappears altogether. I can recover the palettes only by going back to the image browser tab in PL and then return to the ‘customize’ tab.


I tested this on mine to see what you’re experiencing. I pulled a pallet of the sidebar then chose to send it to the right dock and it seemed to disappear too. Then I clicked the top icons to turn them off and the pallet was at the bottom of stack. Likewise if I sent it to the left. See screenshots.

Screen Shot 1
Screen Shot 2
I think this is one of the interface quirks that let us ponder life… :blush:

Tried something …(Win) :slight_smile:

  • created a new user palette [NEW_1],
    which then docked ‘automatically’ at the bottom RHS
  • filled it with any module
  • pulled the palette out to float in the (main) picture area
  • saved the new workspace [new1]

Screen Shot 12-09-21 at 12.35 PM

  • rearranged the floating palette, added another one
    and after restart of PL it appeared how I left it
  • calling the workspace [new1] turned everything back to the saved state

As long the floating palettes weren’t positioned to far to the right

  • they didn’t dock at the bottom RHS,
  • I could activate the hardcoded buttons at the top RHS
  • or collapse the RHS palettes to the right

– the same at LHS.

Maybe I haven’t explained this well. I attach a screenshot of the floating palettes I’m using with the Left Palette showing the menu item I’m about to click to “Dock” the palette.

Once I click this item the palette disappears entirely. It does not go the background or dock somewhere else: it just vanishes until

  1. I go back to the PhotoLibrary then choose the Customize tab again, or
  2. I choose one of the ‘standard’ workspaces and then again choose my personalized workspace with the floating palettes (but then they are un-docked again).

This is not the behavior I expected when I chose to dock my own palettes.



I move the palettes with my mouse and they will snap in place. Never tried the menu command so far.

Recently experienced this myself after selecting ‘dock to right’.
Figured I’d made a mistake!

Only way I could retrieve that pallet was going from Advanced to Basic workspace and back again.
Will have to retry with the latest update and see if it’s still misbehaving.