PL5.1.4 - cannot delete virtual copies (Windows 10)

After updating to PL5.1.4 build 4728, I can no longer remove virtual copies - the option is greyed out in the drop down menus, and using the keyboard shortcut does nothing.


In PL5.0.0 it worked ok for me.

(edit: I just noticed that the inability to delete virtual copies, is for virtual copies made from images sent to PL5 from another app… not sure whether this distinction applied to PL5.0 or not)

My system is running in Windows 10, Version 21H1, OS build 19043.1526 with Windows Feature Experience Pack 120.2212.4170.0

Is this a bug, or is there something I need to do differently?


I’ve just tried creating and removing a virtual copy with the same version of PL5 (5.1.4 Build 4728) on a Windows 10 PC (Windows 10 21H1) and not had any problem.

Note I created the VC from within PL5 and then removed it without any problem. You may be onto something with your observation about VCs “sent to PL5 from another app”). I only ever create VCs in PL (and in fact have no idea what I’d need to do to get a VC “sent to PL5 from another app”) so can’t help any further.

Hello @Rick and welcome to the forum!

Can it be that you try to delete it from the external selections (in this case it’s expected)?
And if, it’s not an external selection, could you, please provide a screenshot of the whole app display?

Thank you,
Svetlana G.

Hi Paul and Svetlana,
From iMatch I send the raw files I need to work with to be opened in PL5, then I create virtual copies as I need them within PL5.

Once I choose the versions of the image I want to keep, PL5 will not let me remove the other (sometimes several) virtual copies. The remove/delete option is grayed out in the drop down and right click menus.

The files are listed in ‘external selections’, but the virtual copies are created in PL5, so I would expect to be able to remove (or at least rename) them while in PL5.

If I open a raw file directly from PL5, I have no problem managing or removing virtual copies, but having to find each image I need to work with individually from PL5 negates the point of using a DAM in the first place :wink:

… If removing the redundant virtual copies cannot be done, is there a way to individually rename them, or have the rejected copies be grayed out themselves?

(Marking it with the red ‘reject’ dot draws attention to the image, whereas I would prefer not to be distracted by it at all)

Thank you for suggestions!

Good morning!

  • Yes this is exactly my guess - you try to remove the copy from ‘external selection’ and it’s not allowed by design same as adding new files to the selection.

We have already discussed this behavior and going to change it but I can’t give you the timeframe right now.

Svetlana G.