PL5.0.1b41 DNG exports unreadable

I just tried exporting Nikon NEF files to DNG and, after 4 minutes, got a file that looks like this…

… in Affinity Photo. And like this…

… in Capture One

But it cannot be read in PL5.

A screenshot of the processed NEF file in PL5 looks like this…

I found that some apps don’t handle DPL’s output DNGs well…

Have you tried to reset the image in AP?

The main point of my post is that DPL isn’t handling DPL’s output DNGs at all.

I’m not sure what you mean. All I did was open it.

Not sure what you mean either. Your copy of PL5 exports DNGs that it can’t read?

Here’s how PL5’s DNGs display and can be worked on in PL5.0.1.41 on macOS BigSur on iMac 2019.

Film strip: 6 .cr2 files (left) and respective DNG exports (right)
As we can see, PL5 can edit its own DNGs.

Image taken on a Nikon D810 - NEF file exported…

Result when DNG selected…

Ah, you’ve got a loading error… This seems to be a specific issue with your setup.
I’ve not had any loading errors for a long time.

:unamused: Most often, deleting the database (and .dop files) resolved the issue.

I wish. Tried both and with different images and still no joy :pleading_face: :woozy_face:

…time for a bug report?

Running DxO’s diagnostic script (attached below) might help them find the source of your troubles.

  • quit DPL
  • start the script
  • open DPL and get the error
  • report the bug and attach the script’s output

(That’s the procedure they advised a while ago) (1.5 KB)

I’ve marked this thread with a “bug” tag and here is the diagnostic zip

DxODiagnosticData-2021-11-12– (736,2 Ko)