PL4 with AMD RX580: Save has Failed Internal Error (Correction failed on the execute stage)


A new update, just to try a random idea, I loaded an old version of AMD drivers. AMD Drivers 17.12.2 Windows 10 64bit. With the older drivers, the export bug does NOT appear and seems to work fine. This is with an older RX500/400 series card.

Hello @dma,

Thank you for the information. It’s an interesting track. I’ve tried the same and also confirm that it fixes the stability issues with a RX 560 we have. We’ve forwarded the information to AMD engineers.

However I’m uncomfortable with recommending to do this for everyone having stability issues with AMD RX 500 series GPUs. This is a very old driver (December 2017), and although it looks to fix DeepPRIME exports, we don’t know what else it may break in PhotoLab or other programs.

So to other people reading this post, I’d say… you might try it but use at your own risk. There’s most likely no big deal trying it: in the worst case you’ll just need to reinstall usual drivers if you have issues with these old ones.

I picked the driver 17.12.2 because it was the last driver from 2 generations of drivers ago. For all I know, a more recent but older driver might also work. You could also try the last driver from the 18.xx generation of drivers to see if that works. I just wanted to go back far enough to avoid whatever bug is present in the current generation AMD driver release.

Some additional testing/summary:

AMD Driver 20.12.1 correction failed on the execute stage error
AMD Driver 19.12.3 correction failed on the execute stage error
AMD Driver 18.12.3 exports never complete, spinning arrow runs forever without error and without complete
AMD Driver 17.12.2 works fine, exports error free with good performance.

1 Like

DXO support recently contacted me and asked me try the latest AMD beta driver 21.2.3 optional recently released. Kudos to DXO for taking the initiative to continue working with AMD to resolve this driver issue.

I am happy to report that for me, the new driver 21.2.3 fixes the export error message with my RX series card. The performance is slightly improved from the 17.12.2 driver as well.

One important note, for some reason the AMD driver when selected under Driver-Settings-Graphics-Advanced-GPU Workload menu to “Graphics” mode (which is the default) I see 100% GPU utilization and high power draw on my graphics card with PhotoLab even when there are NO IMAGES being processed. Selecting “compute” mode however has the same export performance and a more normal 0% idle GPU load when idling and 100% load under export.

I recommend Photolab users try out the new driver and select “compute” mode in the driver settings menu.

1 Like

Hi dma,

I have a AMD RX 550 - - with driver as follows; image

It exports an image with DeepPRIME in about 24 secs - but, I do have to set WinMLUseGraphicQueue = True in the DxO.PhotoLab.exe.config file, to force it to be used by PL.

Regards, John M

Edit: Ooops !! I made that change, (CPU Workload = Compute) and my export time went out to 30 secs (from 24) - - changing it back, and rebooting, made no difference (still 30 secs) … Any suggestions ?

1 Like

One more update, 21.2.3 has been working fine for me. I just let my system update itself to the latest 21.4.1 and the error is back. I have now regressed back to 21.2.3 and it is working again.

This is the only version I recommend at this time:

1 Like

now i have install 21.4.1 and it works great. Before that I had to switch to only one develop from Prime Noise Correction. now I can develop 2 images at the same time as usual. Since I have updated my BIOS and it works now, I think that it has something to do with the BIOS …I have a gigabyte x570 elite board with 32 GB and a 3600 AMD and RX580 graphics card. Update AMD AGESA ComboV2 this is F33h.

1 Like

I also have a motherboard with a x570 chip set. I updated my bios to include AMD AGESA as well. however the error still persists here with the 21.4.1 AMD video driver. Back to 21.2.3 for me.

1 Like

now i have the problem with AMD 21.6.1 driver… my workaround ist that i only export one photo a the time…

did you try to fall back to version 21.2.3?

1 Like

I can’t i must use a newer driver then 21.2.3
So i export one File at one time…
I hope DxO will fix it…

Hello @Artphotowerkst,

You should at least try driver 21.2.3 to confirm that the issue is only coming from graphics driver and not something else. Then you can reinstall a newer driver.

If the issue is in the graphics driver, DxO can unfortunately not fix it, and the best thing to do is to complain to AMD support. You can obviously stay with a single export at a time or change your GPU, but these are only workarounds and not a nice experience.

Best regards,

1 Like

AMD 21.2.3 driver works. I hope there is a way that also new driver from AMD will work in future.


Today, 01/11/2021, the only way to have photolab 5 with prime activated and no error in export file, is to use the adrenaline driver 21.2.3, no way with other driver, also the last. Can you work on this proble? My graphic board is a Sapphire radeon rx580 nitro+ with 8gb of vram, not a recent one but a decent one for my work.
Thanks in advance

1 Like

Hello @Fabrizio,

Our answer on this matter has not changed:

Best regards,

@Lucas Thanks very much. Sorry for the mistake. I managed to get it all working by turning off opencl and setting the graphics card to work and not graphics with the latest certificated driver available.
Best regards.

When I try using deep prime with PL5 on my Fuji RAF files I get an error message from the Adrenalin software (driver timeout). The software shows me a GPU usage of 100 %. When checking with the task manager in windows, the GPU actually is only in use for about 2-3 %. The adrenalin software is giving me wrong results. I have to reset the driver in order to show the proper usage of the GPU again. It seems to be that the GPU is not used properly even when the Graphic card is set under deep prime acceleration in PL5.
Developping photos with deep prime produces the same error. However, PL5 and deep prime seem to work, only not together with the GPU acceleration. When switching to “only use CPU” in the settings everything works fine. No error message. However, it’s a pity that the Graphic card acceleration can’t be used.


Could you, please have a look at this thread - PL4 with AMD RX580: Save has Failed Internal Error (Correction failed on the execute stage) - #26 by Lucas seems you have the same problem.

Svetlana G.


That seems to work. No error messages so far. Thanks for the tip.

1 Like