PL4 install failure on Win10 at validation step

PL3 works fine. Purchased the upgrade to PL4. Trying to install the upgrade and it fails at the validation step. Tried rebooting, downloading new copy of installation file, Windows 10 is up to date, etc. Always the same result with failure at the same step. Any ideas?


None too sure as I have yet to install my trial of PL4 but do not recall any such issue with PL3… have you tried installing ‘as an admin’ user???

Yes. Tried that as well. The installation process doesn’t even create the PL4 installation folder so it appears nothing gets installed. It just quits after the validating message box appears and there is no further details…

Sounds like an OS or user account issue. I’d start with basic troubleshooting. Is there anything in your Windows system and application logs in Event Viewer? (In Windows 10, right-click on the Start menu icon to launch Event Viewer.) If you open Windows Explorer and browse to “This PC,” do your disks look OK?

You can also try this to rule out OS issues:

Hello @PEIGuy1 and welcome to the forum,

Please, create a ticket at and provide them with ‘photolab4_install_log.log’ and ‘photolab4_installer_bootstrap_log.log’ (if they are created) here %LocalAppData%\Temp\

Svetlana G.

Thanks. I was able install after I temporarily disabled the antivirus and firewall software.

Thanks. No need to pursue or create a support ticket. I was able to install PL4 after I temporarily disabled the antivirus and firewall software (Vipre). Once this was done, I attempted another install the installed alerted me to a couple of running programs (ACDSee Pro and ACDSee Ultimate) which I shut down and the install proceeded without any issues. Looking forward to using PL4.

1 Like