PL4.1.1 - Tone curve not working for my .NEF files [Resolved in version 4.1.2 build 48]

I just downloaded the first pictures from my Nikon D810 since upgrading to 4.1.1.

All of a sudden, I am getting a tone curve with maximum 6502 instead of 255. This also means that I can’t edit or even reset the curve.

I have tried it with our other D810 and get the same results.

However, if I open the file first in PL3 and adjust the tone curve there, it is fine when I reopen it in PL4.1.1.

What’s going on? Can anyone else see this?


If I manually edit the .dop file and add something like :

					ToneCurveActive = true,
					ToneCurveMasterPoints = {

Then all seems fine.

But, if I don’t edit the tone curve in PL4, because I can’t, that section is not written in the .dop file at all.

The numbers are the difference between 8 and 16 bit.
I don’t know what you mean with “This also means that I can’t edit or even reset the curve.”


I realise that.

Here’s a screenshot of the curve tool :

Capture d’écran 2020-12-18 à 19.00.44

What do you want to reset on this.


There are no visible points apart from the 0,0 one which doesn’t respond to the mouse.

If I do try and add a couple of points on the curve, if that is all I do, the .dop file isn’t written out on closing PL4

And the Reset buttons do not do anything.

I just opened some fresh pictures from my camera. I do get the 255 maximum.
D750. Windows.


Crossing posts.
I see what you mean. There’s no histogram at all.

Unfortunately, I’ve accidentally overwritten my PL4.0 installation, so I can’t tell if this is new since then.

OK Progress.

I have my own default “Optical Corrections only” preset, which I have edited so that the Distortion setting maintain aspect ratio is ticked.

If I change to the DxO no corrections preset, there is no problem.

So, I tried to edit my own preset and find I cannot add the tone curve to it. selecting it doesn’t change the side of the tool to blue.

For the moment, I am going to have to open files with the no corrections preset and then apply my own afterwards. Which is a bit of a bind but, at least, I can then edit tone curves again.

@StevenL helllpppp !!! Pretty please :crazy_face:

Further interesting machinations…

If I manually add

			ToneCurveActive = false,
			ToneCurveBlueGamma = 1,
			ToneCurveBluePoints = {
			ToneCurveGreenGamma = 1,
			ToneCurveGreenPoints = {
			ToneCurveMasterGamma = 1,
			ToneCurveMasterPoints = {
			ToneCurveRedGamma = 1,
			ToneCurveRedPoints = {

… to my custom preset, then I can reinstate that as the default for new RAW files and everything works fine.

So, in summary, if the tone curve section is not included in a custom preset, the preset editor won’t allow it to be added and, when the file is first loaded, the tone curve is left in an unknown state, resulting in the mysterious 6502 maxima.

@StevenL now I’ve done the detective work, how soon before someone can fix it? :hugs:

Just checked on my other computer, running 4.0.2 and the problem is there too.

On my Mac, DPL 4.1.1 does not produce the strange tone curve values on Mojave. If the values were indeed 6502, the upper righthand end of the curve should be somewhere out in your room.

Maybe a fresh download and install can help?

Reminds me on this post of yours, @Joanna

I’ll check it next Monday. :face_with_monocle:

I’m running 4.1.1 on a W10, 20H2 machine. Tried a bunch of NEF files without a problem. However, none had been edited. I’ll try a few processed in PS3 with layers and others processed in PL3 tomorrow.

OK. This is nothing to do with the type of image file and everything to do with custom partial presets and the preset editor.

Go to the Preset palette, select the “5 - no correction” preset and duplicate it.

Then edit the duplicate.

The edge of the Tone Curve tool should be highlighted in blue.

Capture d’écran 2020-12-19 à 08.49.22

Uncheck the little button

The blue highlight disappears

Capture d’écran 2020-12-19 à 08.50.47

But, at least on my machine, the maximum values have also changed from 255 to 6502!

What is more, although it is possible to reactivate the little blue button, the left edge of the Tone Curve tool remains grey.

Capture d’écran 2020-12-19 à 09.31.01

In fact, if you select any custom preset and go into edit mode, deselect the Tone Curve tool, and hit the Edit button to save changes, the editor quits but without prompting to save the change you have just made.

So why is this causing my original problem?

I am using a custom partial preset as the default preset for new RAW files and that custom partial preset doesn’t include the Tone Curve tool.

It would seem that applying a custom partial preset (that doesn’t include the Tone Curve) works fine after you have already opened a file with a “full” preset (that does include the Tone Curve), but using such a custom partial preset (that doesn’t include the Tone Curve) as the default preset for new files causes the problem of the rogue state of the Tone Curve tool.

In fact, using a custom partial preset (that does include the Tone Curve) as the default, if you watch very carefully as you open a new file, you can just see the tone curve numbers flicker through 6502 before changing to 255.

In summary

Until this is fixed…

  • if you want to use a custom partial preset as the default for new files, it must include the Tone Curve, but this would mean using it after the file is already open (using a preset with the Tone Curve) and has been edited, applying a partial preset (without a tone curve) would cancel any changes you have already made to the Tone Curve.

  • once removed, it is impossible to re-add the tone curve to a custom preset in the preset editor.

1 Like

I’ve tried to reproduce the issue. As you describe, editing a preset without TCurve does NOT work as expected. When Editing the preset, I entered 255 in the upper y value field, which made DPL crash instantly. macOS then popped up the window with the bug report.

Update: I can reproduce the bug with DPL 4.1.1 on Mojave and Big Sur. Bug absent in DPL3.

The text of the report is attached herewith. Crash on Tonecurve (30.9 KB)

Note: DPL offers to create a new “empty preset”. When created and left as is, the preset does not do anything (expected) and does not register in history (unexpected). One must first click to edit the preset before it can be applied. See separate post for improvement.

1 Like

Thanks for the confirmation.

I also just tried opening an unedited picture, which gave me the 6502 values, and simply activating the Tone Curve tool without adjusting anything, which should have been written out to the .dop file but, in fact, upon closing PL4, no .dop file was written.

A quick update on where I’m at until we hear back from DxO.

This all started because I wanted to create an “Optical Corrections only” preset that had the “Keep aspect ratio” checked (it isn’t checked in the DxO one).

So I created a new preset based on the DxO one and started editing it.

Since I wanted to be able to apply that preset to files that had already been edited, I unchecked everything except four optical corrections, so that nothing else would get overwritten.

But I also wanted to be able to use that preset as the default for opening all new RAW files.

As I now know, using such a partial preset as the default caused the problem that is the subject of this thread.


The immediate workaround has been to create two presets: “Optical Corrections only” (without the tone curve) and “Optical Corrections only (Default)” with the tone curve added but not activated. I then set the “(Default)” version as the default for opening new RAW files.

1 Like

Hello @Joanna,

You must NEVER use custom partial presets as default presets; otherwise, behavior of the application is unpredictable. Use only full presets for that.


Aha! Thank you for that information. Unable to find any documentation to that effect and the fact that it works in PL3 (Mac) and PL4 (Windows), I saw no reason to suspect that.

So it seems that as the result of a few days investigation, I have stumbled on the way to solve my own problem - one full preset for the default and another for applying to file already opened with a full preset.

And yet…

  1. it seems to work on PL4 for Windows
  2. it seems to work in PL3 for Mac

Whether it is allowed or not doesn’t appear to be documented and, since it hasn’t been a problem to do it before (and still for Windows), why has this suddenly changed?

We are still left with the question of why it is impossible, in the preset editor on a Mac, to add the Tone curve to any preset that doesn’t already have it, or to re-add it once you have removed it in the same editing session.