PL3: Next photo doesn't appear after keyboard suppression

I use PhotoLab to have a closer look at the photos I’ve taken and erase those I don’t want to keep. To do that I use my keyboard shortcut: Command + Backspace. What is a little frustrating is that once the photo has been deleted Photolab doesn’t display the next one in line, I have to manually choose it from the scroll at the bottom.
Could you fix that?

Hello there,
Are you sure about that? Because it should work exactly that way (selecting the next image)…Both in the PhotoLibrary as well as in the Customize tab…
Which version of PhotoLab do you use?

Steven L.

I repeated the problem over and over again about 30 times yesterday! So I believe it happens.
I have the latest version of PhotoLab running on an iMac (late 2012 model) running on the latest MacOS version.

I’ve tried this as well and it works properly when I test it.

I exported 3 jpegs from 1 NEF.
I then erased the jpegs with cmd-backspace and the jpegs was deleted and the next photo was selected.

This is on Catalina 10.15.4 (19E287) and EA3 build 12.

I recently changed my iMac (to the newest 27’ :smiling_face_with_three_hearts:)
I immediately tried to reproduce the issue that kept bugging me. It disappeared!
Conclusion: if your iMac is too old (it was a 2012 model) then you might expect some random bugs!