PL3 3.2.0 Build 50 - Delay in context switching

Why does PL3 take about 8-10 seconds to come back when you switch away from it (via Command-Tab), then return to it? There is a very noticeable lag in the return, and if you are trying to do something quickly by going back and forth, it completely breaks the rhythm.

PL3 is the only application I have ever seen in all my years of Mac that does this. It does this every time, no matter which application you switch to (even the harmless Mac finder). And it didn’t start doing this until recently, some time after Build 29. It is REALLY annoying.

Mojave w/ 16 GB of memory.

For what it’s worth, switching back and forth on my Windows 10 machine using the Windows equivalent Alt-Tab command is instantaneous with the latest build of PhotoLab.


@RexBlock, are you sure that you run DPL 3.2.0 build 50 on your Mac?
My update check says that 3.2.0 build 45 is the newest version…

Edit: Downloaded DPL from my account yesterday and got build 38 which updated to build 45. Today’s download has build number 50 indeed. Switching is instantaneous though (macOS Mojave 40GB Ram)

on my MacBook Pro Catalina, switching between applications is instantaneous even with DPL v3.2.0
build 50.

MacBook Air 2013 (i7/8GB/Mojave/Build 50): lag <0,5s

Ok thanks everyone. It must be something specific to the OS build on this machine.

maybe not. My iMac is on Mojave too, but it is an all-ssd 25in 8core 2019 machine with 40GB of Ram.
Ram should be no issue on your Mac, unless you have lots of apps open and running, this could make your machine swap, which is specially painful with HDDs.

I can confirm (on Mojave)

Delay here too, but just around a second, not more. But along enough to recognise it. Strange behaviour but not effecting my workflow. Mojave here.

My usual suspect in case of hanging applications or delays is the network. Unplug network cable and disable WiFi. Then, without network, restart PL and try to replicate the issue.

Thank you Calle for your hint.
I have the same Problem with a lag of ~25s.
If network is unplugged, there is no problem with the delay.
First starting PL and then network the problem is renewed.
Some suggestion to solve the problem?
And sorry for my english.

No network cable here, WiFi only. I tried with WiFi off and the delay was still there now down to about five seconds. It has become tolerably manageable, but given PL3 is the only application I’ve ever seen do this, and that it didn’t start until sometime after Build 29, it really should be fixed. There is no reason for any app to behave this way.

Possibly PL3 or a library is paging out when it loses focus? MACOS won’t do that unless you allow it to, or a higher priority app starts demanding memory – which is not the case here. Also could be related to the GPU.

Wow 25 seconds is insane and would have me looking for another solution entirely.

It’s not easy. Isolate connected network drives, try them one by one. Bu there could be other causes.

My network is really simple. Only the iMac and a Canon-Printer is connected via the router by LAN. Disconnection of the printer does not end the Problem.
But the interruption of PL3 ends as soon as I switch off WLAN or disconnect the LAN-cable from the iMac.
I use PhotoLab since years and had no similar problem before installing the last update 3.2. two weeks ago.

I’m getting about 5 seconds here where all other apps are virtually instantaneous. Something’s not quite right…
Mac pro, catalina, 12GB ram build 50.

Curious indeed, I don’t see this delay on my
Late 2012 iMac Mini, quad core i7, 8 GB RAM, unto date Catalina, Build 50 PL3. I do have an 256 SSD because original spinner died and it makes a large difference overall. Video cards? I see similar issues on other photo editing forums so I wonder.

I will tell you what happened in the meantime:
I wrote an email to the describing my Problem on the end of march.
After answering some questions I had to run a dxo diagnostic tool and return the diagnostic data.
Finally I got a mail yesterday from the with a link for a download of a new version of PhotoLab 3.2!
As I can see this update solved the problem.
I am impressed and happy - what a support!

I downloaded 3.3.0 Build 54 this morning and am pleased to report the context switch delay appears to be gone. It comes back in under 1 second now, after having been dragged out to 10 seconds in the previous version.

Whatever you did, thanks for fixing this. It had been altering my workflow.