PL3.1.2 Build 42: Duplication Defects

Duplicate (Command-D) seems to display the duplicated images now. But then …

– delete duplicate
– duplicate disappears (as expected)
– nothing in the viewfinder to edit
– moving around the filmstrip does not add an image to the viewfinder
– in other words, you cannot edit anything

Using PhotoLibrary to leave and return to the same directory usually restores the problem. But shortly after that, PL3 crashes. In fact, I’ve had PL3 installed for about a half hour now, and it has crashed four times.

This is really appallingly poor behavior for a mature application and an existing feature. The Duplication option has been frustratingly inconsistent for so many releases and now that it is leading to crashes, it has become intolerable.

Please fix duplication once and for all.

Hello Rexblock,

tried to replicate this behavior and could not (but I discovered something odd). My steps:

  • I am in customize
  • select a file and create a virtual copy
  • deleted the virtual copy and virtual copy disappears - as expected
  • viewing area is empty - as expected


  • the file located next to the file I just created a copy is selected in the filmstip - so it should show in the viewing area. clicking again on this file does not change anything. it will not appear.
  • if I click on any other file, this file appears in the viewing area as expected.

In other words I can only replicate your behavior on the file immediately following the first file I created a virtual copy of. For all the other files it works as expected.
I do not have to leave and return any directory. I just click on any file and it appears.

I hope I made myself clear.


Yes very clear Sigi. Your reported behavior seems to indicate a defect that leaves things in an indeterminate state based on various circumstances which are probably far too obscure to debug from the user side.

I have removed Build 42 and restored Build 31 from TimeMachine. Looking forward to Build 43.

Hello Rexblock,
there must be something on your machine which causes this. These crashes are not normal.
What is your setup and which GPU do you use.


I believe there is a bug related to filmstrip selection and main viewer window across the board, and not related just to virtual copies. I have detailed this behaviour in another post.

This problem must be generic to Mac Machines as my Win 10 machine performs as expected. Using PL 3.1.0 build 4301.


PL3 v3.1.2 built 42 crashes here macOS as soon as I touch local adjustment icon, haven’t tried nothing else with it.
Sent a ticket to DxO.