PL slow and crashes after installing 5.4

Before installing 5.4 on my Lenovo P52 / Windows 10 machine, PL ran just fine. With 5.4 however, PL reacted painfully slow as soon as I started to use local adjustments.

I then uninstalled 5.4, went back to 5.3.1 (which worked perfectly fine) - but the behaviour was the same with 5.4 - the app crashes as soon as I hit the “Local adjustmens” button.

EDIT: Error code DD9766C1-ACAF-4E96-99D6-D7FFA11CB114

Any tips how to solve this?

EDIT: Went just back to 5.2, which seems to run flawlessly.

I have had the same experience, PL5.4 is very slow, especially for local edits. But no crashes!!
I am using WIN 11 Pro with a Ryzen 9 5900X and 64GB RAM.

1 Like

I have had number of edit crashes as well, being away from internet it couldn’t send reports, but usually when using smart brush

Did you have this problem with new pictures, or with pictures you already edited?

When the problem is with pictures already edited in PL 5.2, try removing the sidecart file of the image. Maybe that fixes the problem?

Dropped a support request at DXO, they sent me a link for a download of 5.4 which solved the problem for whatever reason.

1 Like