PL not reading distance from Sony ARW

Most of my time with DXO software I have used Canon cameras but as I have got older fond it an increasing pain to hump there weight about so have switched to Sony a6000 and a a6400. I have just noticed that the Sony focusing distance isn’t being used. This is with 3 lenses, Sony 16-70, Sony 90mm Macro and Sony 70-350mm I have asked on some Sony forums and have been assured other RAW processing programs do get the focusing information from my cameras and lenses. Somehow PL aren’t managing this, I attach a RAW for any one else to see if they get distance from it.
_DSC6612.ARW (23.8 MB)

ExifTool shows…

 Focus Distance 2                : 6.21 m

… which means that PL doesn’t show it because it is taken into account automatically when making adjustments based on the lens module.

No it shows the option to add the distance you think it should. With all my canon that option is missing. I have looked at some other programs and yes they are showing the distance and on the Sony fourms I was told lightroom aother programs were findfing it as well.


Have you downloaded the lens module?

Although, on my Mac, even without the lens module, I still just get…

Capture d’écran 2022-01-25 à 13.31.30

… just as if the module was there.

Yes the distance isn’t shown if the lense isn’t suported (I use an unsuported phone so am used to losing all the supported options )and just checked and distance isn’t shown for that). I have removed and reinstall all moduals (am in Windows)

From what I can find, specifying the focal distance is only possible when it is not available from the EXIF in the RAW file, which in this case it is. And the lens is supported because I am able to download the module and get automatic corrections.

Since this is a Win/Mac difference, perhaps @StevenL would like to investigate?

Thanks for doing that, it does look like a bug as distance I’s available in other programs.

To my knowledge, PL5 reads the Maker’s Notes in the EXIF but not the Composite section. The Focusing Distance in your file is located in the latter but not in the former. Therefore PL5 doesn’t see it.

The only appropriate Sony tag I can find is Focus Position 2

I wonder if there is any problem with having two similarly named tags and PL not picking up on that?

Maybe @Marie can enlighten us about it.
Marie, are you there? :microphone: :wink:

As you found other programs don’t have that problem or the Mac version of pl.

Yes Focus Position 2 is in the Sony section, but I don’t see Focusing Distance anywhere but in the Composite section, which PL doesn’t read.

So it could be this is a Sony wide problem with windows pl

PL5 also does not read focus distance from ARW files of my A65. There seems to be no corresponding tag here at all.

I have used PL3 (my wife never wanted to change it!) and it apeares to have no problem, or at least no sign of focusing distance comming up. It looks like it could be a bug introduced in V4 or V5.

I just ran a check on one of my Nikon D850 files and it includes…

exiftool -nikon:focusdistance _JNA0006.NEF
Focus Distance                  : 1.00 m

… but PL5 (Mac) doesn’t allow any interaction with the Focusing Distance tool, either with or without the relevant lens module.

I just checked PL3 and PL4 and get the same result.

So, with a Sony file, Focus Distance 2 can be found but with a Nikon file, it’s Focus Distance but neither file activates the Focusing Distance tool in PL3, PL4 or PL5.

Have tried contacting support but the new nightmare system refuses to take a request just keeps coming up with pleases add a number. Well its one way of reducing the workload!

Interestingly I have opened some of my wife’s images and found a Zeiss Touit 50mm works OK , distance is read. I attach it to see if there is something different with it.
DSC00188.ARW (23.8 MB)

Joanna, if it doesn’t active the FD tool that means it’s reading the distance correctly. You don’t have to enter the distance manually. Same on Win, just the FD tool doesn’t even appear.

The EXIF in this file is the same as in the first one, and yet this one does not ask for FD. :flushed: :man_shrugging: