PL: issue on exporting SOME raw files and not others!

I’m exporting a bunch of .CR3 files.
For some weird reason, some files (successfully edited in PL6), failed to export in TIFF, while other similar ones works great.
All files are all from the same camera (canon R6), and all properly renamed the same way.

When exporting I have this message :
Capture d’écran 2022-11-02 à 09.59.02

In block SaveWithoutFormatDeduction [path of the file]

PL6 failed to export those files in TIFF (16, 8 bits, 8 bits compressed) .
BUT, if I select another format for export ( JPG or DNG), then the export works well!

Wondering if it could be a combination of setting in PL6, I have copy settings from an image that can export properly, to an image that failed to export. It din’t worked.
Wondering if it was a PL6’s bug, I tried with PL5. Same issue.
Wondering if it could be a hard drive issue, I used another hard drive, didn’t make any difference.
I have re-installed PL6; It does not make a difference.
I tried to export them with LR, it worked great.

What I have noticed, is that all the files that can’t export, are consecutive files (taken in a row during a period of 20 min, and then, other files works well). So wondered if it could be a setting from the camera that I would have change by mistake? Or maybe files would have been altered during transfert from card to HDD (using PM). ?

What’s going on?
I am using MacOS 11. I never had such issue before. I would like to understand to prevent it to happen again.
Verry weird issue. Let me know if you have any clue!
I would be happy to share a file.

Yes, please share a file along with the DOP file that goes with it so that we can try to reproduce the error.

Here is a zip with the original image in .CR3 , it’s .DOP and .XMP (20,8 Mo)

Even though I got an error message too, the file exported to JPEG and DNG, but not to TIFF, which I only got by exporting a DNG again.

Check this out:

[ExifTool]      ExifTool Version Number         : 12.41
[File]          File Name                       : 20221015-16192958.CR3
[File]          Directory                       : /Users/platypus/Desktop/Archive
[File]          File Size                       : 21 MiB
[File]          File Modification Date/Time     : 2022:10:15 23:19:30+02:00
[File]          File Access Date/Time           : 2022:11:02 20:45:13+01:00
[File]          File Inode Change Date/Time     : 2022:11:02 20:45:13+01:00
[File]          File Permissions                : -rwxrwxrwx
[File]          File Type                       : CR3
[File]          File Type Extension             : cr3
[File]          MIME Type                       : image/x-canon-cr3
[File]          Exif Byte Order                 : Little-endian (Intel, II)
[File]          Exif Byte Order                 : Little-endian (Intel, II)
[File]          Exif Byte Order                 : Little-endian (Intel, II)
[File]          Exif Byte Order                 : Little-endian (Intel, II)
[QuickTime]     Major Brand                     : Canon Raw (.CRX)
[QuickTime]     Minor Version                   : 0.0.1
[QuickTime]     Compatible Brands               : crx , isom
[QuickTime]     Movie Header Version            : 0
[QuickTime]     Create Date                     : 2022:10:16 00:19:29+02:00
[QuickTime]     Modify Date                     : 2022:10:16 00:19:29+02:00
[QuickTime]     Time Scale                      : 1
[QuickTime]     Duration                        : 1.00 s

Possibly, the TIFF export struggled with the file’s QuickTime tags?
If this should be the case, DxO should have a look at the file.
attn @Musashi

Hi @platypus .
Thanks for checking.
I’m not sure to know what are QuickTime tags, and how they are generated.
Are they generated by the camera? Or by PhotoMechanic (where I apply some IPTC to the files). Or by PL ? Or by MacOS ?

Finally, in the extract of the Exiftool you are showing, what do you think is wrong? Is that the fact that we see [QuickTime] instead of something else?

If you can also post an image that doesn’t throw an error on export. I could compare the two files’s metadata.

QuickTime relates to movie files and was introduced by Apple many years ago. Canon adopted the format for video recording in early cameras.

I have no idea how those QuickTime tags got into your RAW file, except maybe by some camera setting* or an external editor that might have added the tags. I’ve looked at the file with Canon DPP (current version) and found no clue to video content.

Note* Can an R6 be set to record images before you press the shutter release?

Find here another image, from the same camera, few min later, that don’t have any issue being exported.

All that is pretty weird.

And to answer you question. Maybe. I usually work with 2 cameras, one camera hanging on my waist, still-turned on, therefore, there are sometimes some surprises. So, that may have happened, but I don’t recall it. And I just check my camera’s settings, it’s pretty unluckily that it had happened.

And finally, I just tested to record video and switch to photo and I managed to export all files with PL without issue.

Let me know if this other file have the QuickTime tag.

Archive (21,3 Mo)

I just tested to open both images with canon DPP, and check the Exif Infos.
The Exif tab is empty when I check the image that doesn’t not export properly.
It’s like if the Exif part has been corrupted. Is that possible?
thought, Exif datas still works with some other software… and even PL seams to read them.

I took a look at the EXIF for both of your images(Quicktime info is present in both images) and while I haven’t looked exhaustively at the EXIF, I did find one odd difference:

In the image that refuses to export, on the lens information there is an odd symbol.

This symbol is not present in the EXIF on the image that does export. The lens info reads correctly.

I downloaded the proper lens module “Canon EF 70-200mm f/2.8L IS II USM” and used it on both images. I can confirm that a Tiff version of the 1st file will not export(although DNG will) and there is no problem exporting the 2nd file in any format. How this oddity could affect the export of Tiff files only, I have no idea and doubt that this is the problem, but I thought that I would report the difference to you. I’ll keep looking.

Checked the files, also agains files from All image files seem to have the QuickTime section.

I’d get in touch with

Thank you very much

Thank you very much. weird, weird, weird. is like the file have been corrupted at one point.